MobileNet assignment (week 2) - trainin and validation plots not showing up (+loss and accuracy not improving with each epoch)

In the MobileNet assignment (week 2), I get “All tests passed!” for all of the exercises. However, when I run the model it does not seem to work. For example, accuracy is stuck at 0.4466. Also, trainin and validation loss plots do not show up:


The last fine-tuning exercise does not help either (still stuck at 0.4466) and the same plotting problem.

By the way, when I submit, I pass with 100% grade which is very concerning because it makes me think that maybe I have been actually making a lot of mistakes in the previous courses of the specialization without even noticing :(. What might be wrong?

Hi Zav,

Good that you are reporting this. There is at least an issue with the variable base_model which is used as a global as well as a local variable. I have reported this to people working on the backend. I noticed that when I resolved the issue with base_model I got similar results of low accuracy, so there is more to look into. @Mubsi


+1 to this.
Getting the same results as model is not improving, tried different fine_tune_at values, but the layers didn’t seem to train.