ModuleNotFoundError in Jazz Improvement with LSTM

No module named keras is coming up again and again when I tried running the packages’ cell. I even contacted the customer care, but they said that they couldn’t do anything to fix it. Please help as I have been stuck for 15 days

In your assignment, you can refer keras members with tf prefix like tf.keras.layers.Dense.

please send the screenshot of the packages, as it’s still showing an error

I’m afraid that you are using an old notebook. Keras is no longer an independent package to cover multiple backends, but is part of Tensorflow. If so, it is better to refresh a notebook so that you can work on the right assignment. Here is the link.

When you have an error, it is most helpful if you include a screen capture that shows the error.

this error is coming when i use the tf prefix

and this is coming when i don’t make any changes to the packages’ cell.

Sir, i followed the steps given in the link you’ve provided, but the error is still there.

I’m not sure where your code came from, but here’s what’s in the assignment notebook.
You’re missing an important line.

If following the “get a clean copy” procedure that Nobu linked did not work, that probably just means you did not follow the instructions correctly. Note that procedure only replaces missing files, so it does nothing unless you rename your notebook out of the way first. That was explained in the instructions. Please have another try and go through the instructions carefully and let us know if you still have a problem.

Sir, I have tried doing this 3 times, but it doesn’t make a difference.
I don’t think there is any missing file

Are you sure you moved your existing notebook with the old code out of the way first? That is the point about “missing files”. Nothing happens unless you either delete or rename your old notebook first. The instructions are quite clear on this point.

Yes sir, I renamed the file as shown in the instructions. But it made no difference

Ok, I am officially out of ideas then. The only other thing I can think of is that somehow you are stuck in a very old version of the course, although I have no idea whether that can actually happen or not. You might try asking the Coursera Help Center to make sure you are enrolled in the current version of the course. See the last topic on the FAQ Thread for a link to that.