NLP-C4_W3 Graded Error

Graded Error.

Test Cases all passed in JupyterNotebook

1 Like

Please click on the > marker, and that will give you a text box that has the grader feedback.

That should give you more info what the problem is.


Grader Feedback Error

1 Like

I’m not a mentor for this course, but I don’t thik anyone else is active right now.
So I’ll make a couple of general suggestions.

Grader errors like this are usually due to:

  • Using a notebook that is obsolete. If the notebook or the grader has been updated, you can’t submit it.
  • Do not add new cells to the notebook.
  • Do not add code outside of the “START CODE HERE” sections.
  • Do not use global variables.
  • Do not use hard-coded constants.

General tips: Restart the kernel and clear all the output. Then use File → Save and Checkpoint, then run all of the cells in the notebook gain, and check the results for any errors.

Do not submit your notebook until it passes all of the tests.

Or, Coursera could simply be having technical issues, and you can only wait until they fix it.

1 Like

I have actually did all of the above you mentioned. Also tried with restarting kernel, restarting a fresh notebook, Re-run all the code and make sure All tests passed.

I have also tried with submitting notebook with some test cases failed, the problem still preserved, It seems like it is not detecting my notebook or smt.

1 Like

Did you change the name of your notebook? That would be bad.

If you have tried a completely fresh notebook and still get the “Grader Feedback not found” error, then one more thing that is worth trying is:

  1. Kernel → Restart and Clear Output
  2. Save
  3. Submit

The point is that the grader does not need to see your output: it only needs to call your functions. Running the notebook can increase the memory size significantly, especially if there is a training cell that runs lots of iterations. That’s why it can potentially help to “Clear Output” before submitting: it minimizes the memory size of the image you are submitting to the grader.

The problem still occurred…

Are you sure that you are clicking “Submit” in the “official” version of the notebook? The one opened by the “Work in Browser” link? Note that if you are in a renamed copy of the notebook, clicking “Submit” submits the “official” version, not the version you are actually running.

Excellent point, I keep forgetting this.

If I’m remembering correctly, I think we at least once saw a scenario where there was some syntax in the generated output from a notebook that caused the grader to barf. So it can in theory be a benefit to “Clear Output” even independent of the memory size issue. But maybe that was a “one off” scenario …

I’ll send u step by step on how I do it with screenshot. Please let me know if I have done anything wrong.

  1. I clicked “Launch Notebook”

  2. I go to “Navigate”, and then I rename directory from “/notebooks/C4_W3_Assignment.ipynb” to “/notebooks”

  3. This bring me to the “/tree” directory, as you can see, all of the notebook are official. Screenshot:

    Edit: I have deleted the “Untitled.ipynb”

  4. I did create a copy before, but I have deleted it, and the new official notebook was generated by adding “?forceRestart=True” in the url, that brings everything back.

  5. I re-click on “Launch notebook”, and complete the code, test cases, etc.

  6. The problem still occurred.

  • I have also restarted kernel, cleared output, submitting file with only functions. This is just to show that my function is actually working, but grader is not reading it for some reasons.

Thanks for the details. Sorry, but I’m in the same situation as Tom: I am not a mentor for this course, so can’t directly try any experiments here. We’ll need to hope that one of the NLP mentors will notice. Or we could try pinging the DLAI staff and see if they can take a look.

Thank you for your efforts @paulinpaloalto and @TMosh. I can take it from here.

@sunsunkiesun, I shall send you a DM to take a look at this.

This was written in the instructions saying that we could re-name our notebook:

" Tick the checkbox again and this time choose Rename and enter any filename other than the original. For example, C1_W1_Assignment.ipynb (original) → C1_W1_Assignment_v2.ipynb "

Sure you can rename it if you want to keep multiple copies with different implementations for experimentation. You can also use “File → Make a Copy” in addition to “Rename”. But the key thing to remember is what I said earlier: if you click “Submit Assignment” in a copy, it does not grade the copy. It grades the original notebook (the one opened by “Work in Browser”), so you may get surprising results. I totally agree that this is a clear violation of the Principle of Least Astonishment as the UX experts call it. But we have to deal with things “as they are” as opposed to “as we wish them to be”. :nerd_face:

If you want to get your copy graded, then you have to rename the various notebooks so that your version has the standard name and gets opened by “Work in Browser”.

That just lets you save your working copy, so it isn’t gone forever. You can use it for reference. But you can’t submit that renamed notebook for grading.

Hi @sunsunkiesun,

First thing is first - before you submit your assignment for grade, you have to fill in the code for all of the graded exercises. I see you haven’t attempted Ex 4 as of yet, which is probably why you are facing this error.

Make sure that’s also done and you are passing its unit tests before submitting. And if the error remains even after that, let us know.


Error remains, dmed you.

Hi @sunsunkiesun,

Will take a look.