Notebook in cw_w3 grading problems

I am having auograder trouble in C2_W3 the notebook TENSORFLW INTRODUCTION
I finally finished this Notebook yesterday w/o any apparent errors but I only received a 80% although this was passes So I again stepped through the notebook again today to see if I might improve the score and this time Ireceived the message Success - all notebook tests passed BUT now I received a 0% grade! and was not passed

Here is the autograder code

did you try to refreshing you workbook environment and then connect the kernel properly, run all the cell one by one, then submit your assignment again?

Thanks doe your reply. How do I know that the notebook is refreshed and the kernel connected?


your error log clearly mentioned interrupting kernel that can happen only when there is a network issue or your notebook did not upload properly.

It also mentioned Timeout waiting for execution reply which again mentions, your kernel got disconnected while submitting your assignment.

Your error log always gives you lot of hints on why your stuck in your assignment.

your refreshed notebook will always have your notebook connected with your kernel, showing on top as Trusted. if there is a network issue, it automatically get disconnected and shows on top of the assignment. So any time before your submit, make sure to save and checkpoint your work and then submit.

These all instructions are mentioned in reading instructions before your assignment page.

The output from the grader frequently leaves a lot to be desired. There must be some problem with at least one of your functions, but we get absolutely no help from the grader about where the problem is. We’ll need to look at your notebook in order to diagnose this. Please check your DMs for a message from me about how to proceed with that analysis.

I tried again. It says trusted at the top and when I click on this - no options appear. I also selected reconnect on the kernel However I am still getting the exact same autograder response that I sent you before. Even with no apparent errors when I again run the code, I am still getting only an 80 percent grade

Thanks for your help

@Lawrence_Kent I think there must be a problem with your code. We need to look at your code, but we can’t do that directly. Please check your Direct Messages for a message from me.

1 Like

I tried pressing the validate button - this just appears to hang - I am not sure what it does because the code still appears to work.

Are direct messages sent to my email? I have spent a lot of time already on this and so I am a little reticent about spending a lot more time. Even with the error I have still have passed and I think I understand the material pretty well. So I just might go on. If the auttograder often has problems, how important is it to proceed?

That’s fine if you just want to move on. DMs come to your Discourse feed just like replies to threads you subscribe to, but they just have a different icon: a little envelope.

I did try one more time, but this time i restarted the code and also cleared the previous output as well. This time I did get an error so perhaps the autograder was correct. The error (wrong output) occurs fairly far along in the test code only after exercise 5 forward_prop codes is executed without a problem. (I strongly believe that the codes in the forward_prop of exercise 5 is correct.) What is weird is that all the preceding code modules were completely passed. So I don’t know whether this is identified correctly as an error, or is still a problem with the kernel.

Well, there is a lot of code besides the forward propagation. The one hot conversion logic also frequently trips people up.

You can send me the notebook in the way I described in my recent direct message.


Can you share a screenshot of the grader output where you scored 80/100

it will mention why your grader failed.

Also send your notebook via personal DM. Click on my name and then message.


Do I just click on your name - I don’t see any little envelope - and the just copy and paste the notebook into that window?

I did send you the C3_W3 notebook - I am hoping I did it correctly

Not yet. I replied on the DM thread that you started. You should see the responses the same way you see normal responses.

Thanks for your response

Can I just paste the autograder code here (since this is not the notebook itself)?

You can paste the autograder output here, but you did that earlier and it didn’t help, right?

How about pasting or posting a screenshot of the actual error that you are getting when you run your notebook. You mentioned that the “one hot” routine passes, but then it fails after that.

Here’s a thread about that type of problem that may be relevant.

Does this error message look familiar:

ValueError: Shape must be rank 1 but is rank 0 for '{{node Reshape}} = Reshape[T=DT_FLOAT, Tshape=DT_INT32](one_hot, Reshape/shape)' with input shapes: [6], [].

I don’t think that’s the error. Again I hope this gets to you I will also try to again lad the notebook to you Thanks for staying with thiis issue


That is a link again to a non-existent URL. You need to use the “Up Arrow” highlighted in this screenshot:

I have sent you a number of similar responses on the DM thread that you started.

Here is the notebook - sorry about that
Was the screenshot helpful

{moderator edit - solution code removed}