Plt_quad_logistic - W3

Hi, I cant find the file for ‘plt_quad_logistic’ in the C1_W3_Lab06_Gradient descent.

Hi @Giulia_Wu

I believe there is no file called plt_quad_logistic in the lab files. but I think what you mean is no function is called that.

Please, make sure to run all the cells from the above to down as you might miss a cell that imports this function for you.

@Giulia_Wu just to make sure, did you execute the very first cell of the lab? that’s where the notebook will import this library. If you did that and still cant find it, then I would suggest reloading the lab. For that, click on the upper right corner “Help” and then click “Get latest version”. If you’ve done some work already, please save it first.

What I have been doing so far was downloading the files for each lab and tried to execute the lab/write the codes on my local Jupiter.

However, even though I have written the exact same code (with all the files downloaded), it seems that I the function ‘plt_quad_logistic’ is missing/hasn’t been imported.

@Giulia_Wu
Please, Just check your syntax on the function name as everything should work just fine on your local machine if you set it up correctly.

@Giulia_Wu , the fact that you are trying to run this in your local environment may explain everything: Even though you may have copied the lab and all additional files to your local environment, the versions of all the associated python packages in the Coursera labs may be different from what you have in your local environment.

Have you tried running it in the Coursera labs environment?

Juan

Hello Giulia @Giulia_Wu,

  1. Open the lab again on coursera
  2. On the menu bar, click “File” > “Open”
  3. Check out the file list for plt_quad_logistic.py
  4. If you can find it, then download it by selecting the file then click “Download”
  5. If you can’t find it, then click “Help” in the top right corner, then click “Get latest version” > “Update Lab”. Any missing file will appear and then you should be able to find plt_quad_logistic.py

Raymond

PS: I moved your thread to under the category of MLS course 1 week 3.

1 Like

Hi @rmwkwok, thank you for the suggestion. I have updated the file as you said, but the file is still not there. I can only see the plt_quad_logistic in pyc file, but i supposed that is not what i need?

Could you please share screenshots of the full file list here? It should include the lab in question.


Hello Giulia @Giulia_Wu,

Thanks for the screenshot but I am afraid I will have to ask you once again, because I hope you can follow the steps below and take another screenshot at step 3. After step 2, you will be brought to a file list, and I hope to see what are included there.

I am NOT asking to click the “Lab Files” button in the top right corner.

Raymond

Screenshot from 2022-10-25 18-04-15

For your reference, click “File” in the menu bar, then you will see a dropdown menu, and the second button is Open. Please click that Open button.