Problem with C1_W1_Lab03_Cost_function when I run it in my computer

Hello! when I Try to run the first cell of the code I get this error (see image) and I don’t understand what it is. Please if someone could help me I will appreciate it very much.

Are you using the Coursera Labs environment?

Hi @Pamela_Carolina_Diaz
Welcome to the community!

If you run the assignment in your PC, please follow these steps when you download the assignment

Best Regards,

I did followed all the steps, I downloaded all the files. Now Im getting the error showed in the image. The file deeplearning.mplstyle in in the same folder as the notebook. So I do not understand what is happening.

I am having the same error in Jupyter Lab. I attached a screenshot from Lab showing that the file is in the same directory as the notebook. Let me know if I am doing something wrong- appreciate all the help!

You probably need to install numpy or other missing packages in your python environment.
The bash command to do it is:

pip install numpy

Has anyone solved this problem?
I get the same error when I download the files and run it on my PC
I have the latest version of all packages. Do I need to install a specific version of Python and the libraries used in this notebook? And if so, how can I do it?

That’s probably bad. The tools on Coursera are not the latest versions.