Rate Limit Error - You exceeded your Current Quota

Hi dear community.

Running at my laptop the Jupyter Notebook of the Guideline lesson of the course ChatGPT prompt Engineering, I got the error message below on my the first interaction.

“RateLimitError: You exceeded your current quota, please check your plan and billing details.”

I’ve loaded my own API key as oriented but with the free trial it seems that it is not possible to practice the course.

Do you know if it is mandatory to acquire a plan to run the notebooks of this course without limitations?

Thanks in advance.

I am not a mentor for that course, but I believe you’re supposed to use the key provided by the course. Not your own key.

When I try to use course key I get authentication erro, see below. That is why I tried to use with my own key :frowning:

AuthenticationError: No API key provided. You can set your API key in code using ‘openai.api_key = ’, or you can set the environment variable OPENAI_API_KEY=). If your API key is stored in a file, you can point the openai module at it with ‘openai.api_key_path = ’. You can generate API keys in the OpenAI web interface. See OpenAI API for details.

I think you can find a solution if you use the Forum search tool for “api key”.

1 Like

You can only use the course key running in the course environment. You can’t use it locally. If you do get your own trial key, you can indeed run the short course exercises locally; I have done so. The free trial API key has rate per unit time, total $, and duration limits - it only lasts a couple months even if you never use it, so eventually you’ll have to buy a subscription or move to one of the emerging open source LLM projects.




could you find any free solution? I am struggling with the same problem.

FYI, you can pay for the requests, is not expensive. If you use it with gpt3.5 then with 1$ you can make a lot of requests.

I’m using this dashboard to see the cost of the request, and until now I have spent only 10 cents :slight_smile:

did you also try the shared jupyter notebook on the left side of the web page ? It’s funny but I was ignoring that and tried to use another notebook so I had the same problem.