Tensorflow version being checked in the beginning of the C1W1 assignment

I am trying to pass the C1W1 code assignment and in the beginning of the code, right after the import cell, there is a cell that checks tensorflow version.

I have tried deleting this cell and also importing tensorflow in another case, but neither have worked. there is some sort of bug that keeps the notebook from being saved. I wrote all the parts that I had to write, and all of them were saved but this cell does not want to change.

there is a problem with saving the notebook, and autosave.

what am I supposed to do?

Hi @Mowh3n ,

Unless you are working outside of the Coursera platform, there is no need to made changes to the assignment. Where your code is to be added, there are pair of comment lines to indicate that. Some cells are locked to protect from editing, such as those you mentioned.

Hi Mowh3n!
I am really curious to know why some learners import TensorFlow, here. These assignments use PyTorch as their framework ( Entire GANS Specialization ) and there is no cell that checks TensorFlow’s version. I have seen 2 or 3 posts regarding this, where they try to import TensorFlow.
There is no need for you to import TensorFlow here, in these assignments. If you are importing it for experimenting with something, then remove that line before submitting.

Uh oh! That cell that checks the tensorflow version is in the assignment itself. @Nithin_Skantha_M, you can see it if you load the latest version of the assignment. One of the developers must have accidentally included that cell when they updated the assignment somehow. I’ll report it to the developers so they can fix the assignment.

In the meantime, @Mowh3n or anyone else who runs into this before it’s fixed, you should be able to work around this by just commenting out the tf.version line:


The problem has been fixed. Thanks, @Mowh3n for pointing out this issue!

Oh!! I couldn’t see it that day when I tried to load the new version. Maybe I didn’t load it properly or I don’t know. Anyways, I’m sorry for that and thanks for pointing it out @Wendy :raised_hands: