Trigger Word Detection programming assignment not working

Hello, I have some problems with the Trigger Word Detection programming assignment. Even if in the notebook I pass all the test cases, the grader returns 0/100 points with the error for Exercise 7 saying “Sorry, your submission was incorrect. Please try again. Expecting value: line 1 column 1 (char 0)”. The problem is that the notebook only has 5 exercises and I don’t know how I could fix that.

Have you done any of these?

Important Note on Submission to the AutoGrader

Before submitting your assignment to the AutoGrader, please make sure you are not doing the following:

  1. You have not added any extra print statement(s) in the assignment.
  2. You have not added any extra code cell(s) in the assignment.
  3. You have not changed any of the function parameters.
  4. You are not using any global variables inside your graded exercises. Unless specifically instructed to do so, please refrain from it and use the local variables instead.
  5. You are not changing the assignment code where it is not required, like creating extra variables.

No, I’m not doing anything similar in my code, if you want I can share it

Now I also get the error “Sorry, your submission was incorrect. Please try again. Invalid control character at: line 186 column 69474 (char 376832)”

What is the file name you are submitting? Have you renamed it?

Also, try getting a clean copy of your notebook and do the code (or copy it from the old notebook) again.

Hi @Giuseppe_Alessio_Dim,

Firstly, to clear things, when the autograder shows “Exercise 7”, it does not mean an exercise from within the assignment. In autogravder’s language, Exercise 7 is the number of the assignment of this course. You have 3 assignments in Week 1. 2 in Week 2. and 2 in Week 3, making it the 7th assignment of this course.

Now, I tried running your assignment, everything worked and I got full grade. Can you try submitting again and let me know what happens ?

I have deleted your latest copy of the assignment in the workspace and renamed the copy of the assignment you were working on with the default name, so now you only have one assignment in your workspace. Submit that.


Now it works, thank you very much @Mubsi. I previously tried to delete the last copy in the workspace too, but it wasn’t working. Can you explain me how did you do it in order to know how to tackle the same kind of problem in the future?

I didn’t do anything. I just ran it and everything worked.