Week 3 - Trigger Word Detection

Hi,

Despite passing all the tests, the grader first gave the following message:

“Sorry, your submission was incorrect. Please try again. Invalid control character at: line 2098 column 1305193 (char 20955106)”

I then restarted the kernel and cleared all the output. Now it is saying

“Sorry, your submission was incorrect. Please try again. Unterminated string starting at: line 246 column 8 (char 2661911)”

This is extremely frustrating. Obviously, I cannot debug through the grader and the message itself doesn’t say much for obvious reasons. Presumably, this has to do with the json file containing the pre-trained model parameters. Can someone take a look please?

Hey @roccoluca,
Welcome to the community. If your implementations are passing all the test cases, and still you are getting this error, then you may try to fetch a new copy of the assignment, and move your code into that, since it seems like you have changed something involuntarily that you were not expected to, or perhaps, this could be a glitch from the Coursera’s side as well.

You can get a clean copy of your assignment by following the instructions in this thread. But make sure to download your existing notebook, so that you can easily copy + paste your code in the new copy. You can find the instructions to download your existing notebook here. Let us know if this helps.

Cheers,
Elemento

Please post a screen capture image that shows the entire grader message, and any asserts.
That will contain more information than the text copy-and-paste you included.

Just posted it above

This worked. Thank you.

I am also facing this issue, I haven’t run into this in any of the preivous assigments. It feels like something must be weird with this notebook.

I tried submitting multiple times and the issue is more or less same. Simple restarting of kernel didn’t help. Though, doing submission after running “Restart & Clear output” seems to have solved the issue.

I would have expected that the evaluation happens in its own jupyter session and that it shouldn’t have anything to do with saved outputs.

1 Like

Just had a similar issue. The grader failed my submission reporting:
“Sorry, your submission was incorrect. Please try again. Expecting value: line 1 column 1 (char 0)”.

Submitted again without changing anything and got:
“Sorry, your submission was incorrect. Please try again. Invalid control character at: line 2022 column 1880009 (char 16760802)”

Did the kernel restart and clear outputs and re-submitted, again without changing anything, and it passed. Haven’t had any issues with the grader till this assignment.

Hey @mathia,
Welcome to the community. Since many of the learners are facing an issue with the auto-grader of this assignment, I will report it and the team will look into it. Thanks for reporting @mathia and @vangap.

Cheers,
Elemento

I am also having this error just now, after two submissions attempts.

I also tried the reset, renaming the old notebook, updating to latest, copying in my code from the old notebook, all tests passed, and still the control character error when I submit.

I’m not sure if this was the actual error or not, but I noticed the test sections success statement, “All tests passed!” had a weird escape character at the beginning.

print("\033[92m All tests passed!")

I edited out the “\033[92m” part for each of those statements and it was graded correctly.

Hey @Adam_Moses,
Thanks a lot for letting us know, and your solution. I will convey this to the team as well, since I already created the bug report last time it happened.

Cheers,
Elemento

Hi @Adam_Moses,

Can you direct message me the version of your notebook which was causing this error ?

Thanks,
Mubsi

Hey @Adam_Moses @mathia @vangap @roccoluca,
Can you please let us know whether you were working on Coursera Labs or on your local system? If former, then please post your browser configuration here, and if later, then please post your OS configuration here. It could help the team to investigate this issue further.

Cheers,
Elemento

I was working on Coursera labs.

OS: Mac M1
Browser: Google chrome, Version 106.0.5249.119 (Official Build) (arm64).

I don’t know the exact version of chrome when this happened. It would be the latest or -1 version of latest at that time.

@Elemento @Mubsi

I was working on this through Coursera, not on my local system.

I am running Firefox 106.0 on Windows 10.

Server Information:

You are using Jupyter notebook.

The version of the notebook server is: 6.0.3
The server is running on this version of Python:

Python 3.7.6 | packaged by conda-forge | (default, Mar 23 2020, 23:03:20) 
[GCC 7.3.0]

Current Kernel Information:

Python 3.7.6 | packaged by conda-forge | (default, Mar 23 2020, 23:03:20) 
Type 'copyright', 'credits' or 'license' for more information
IPython 7.14.0 -- An enhanced Interactive Python. Type '?' for help.

Hi @Adam_Moses,

Can you direct message me the version of your notebook which was causing this error ?

Thanks,
Mubsi