Trigger word - Grader problem 0/100

Hi! I passed all the tests and my code did everything that was required. However I get a 0/100.

I get the following message:

Sorry, your submission was incorrect. Please try again. Invalid control character at: line 851 column 1810311 (char 9293812)

Could you please help me out?

1 Like

In general, passing the unit tests does not guarantee your code is perfect.

But first, to clear the decks:
Try restarting the kernel and clearing the output, then run all the cells, check your results in detail , and then if it looks OK, then submit it again.

Please post back your results.

1 Like

I have a similar problem. I restarted the kernel, cleared the output, and even used a fresh new file. There were some commented prints where I tried to uncomment and check again. None of them helped and I still get the same error. My outputs seem correct. This is the error I get:
Sorry, your submission was incorrect. Please try again. Expecting value: line 1 column 1 (char 0)

1 Like

I’m not sure what causes this issue (“Expecting value…”). It was reported by one other student a couple of days ago.

Just a thought, have you ever 1) added a new cell to this notebook, or 2) renamed the notebook file?

1 Like

I renamed the notebook after the grader issue to get a new unedited file. I submit the one with the original name. Regarding a new cell, there is an empty cell at the end of the notebook. I tried to remove it and submit the notebook again, but no luck in changing the grader output.

1 Like

Update for other students who find this thread:

Try using “Kernel → Restart & Clear Output”, then “File → Save and Checkpoint”, then (without running any notebook cells), submit the notebook for grading.

This seems to help the grader cope with notebooks that have a lot of data in the “output” cells, like audio files and spectrogram graphics.