Trouble to load_mistral_api_key()

Hello, I am trying to run the jupyter notebook of the course through La Plateforme API. I was able to import load_mistral_api_key from helper but I am not able to run load_mistral_api_key():

What should I define for DLAI_MISTRAL_API_ENDPOINT?

the DLAI_MISTRAL_API_ENDPOINT is the actual endpoint you receive when you register for the Mistral AI API](Mistral AI API | Mistral AI Large Language Models)

As far as I can see I have only received an API key, nothing more…

Also since I pip3 install mistralai, anaconda navigator does not open anymore…

Kind of lost here.

Hi… I’m having trouble on my end too.

I didn’t receive an endpoint either, so I tried the same tactic I used for the Unstructured short course (remove/comment out the URL endpoint altogether). But it doesn’t seem to be working this time unfortunately - I keep getting a 401: Unauthorized error. I definitely have the right API key.

Hi Martin, I finally modified the file as attached and now it works (1.9 KB)

Good luck!


Ah I see what you did there fof - I didn’t have it quite right. This is working for me now. Thank you very much!

On a side note… is it just me or are Mistral’s models REALLY fast?!

1 Like

Indeed quite fast!

I’m also having trouble finding the right dlai environment string - could anyone share what the string is supposed to be? I did not get an associated endpoint when I got my API key.