Unable to upload ipynb/pkl files

I have both the assignment files on my laptop. However, when I am trying to upload these via “My Submission”, even when I select those files, its not getting uploaded - and as a result, the submit button is grey. What am I missing?

Just guessing, but you might have forgotten to click the upload button after you select the files. I believe you have click that button to complete upload. Then, you click submit to submit. Let me know if that was the case.

Thanks for the response, but unfortunately, that’s not the case.
I clicked the blue box for the “Graded Function” which opened up the window that contained the .ipynb file. I selected that file and clicked open (there is no upload button anywhere). But once I select that file, the upload bar flashes for a second and then vanishes. Nothing else happens.
Same for the “Training History” box.

Hello @Avik_Biswas ,

Can you please give the screenshot here so that we can understand where it is going wrong?
I guess you are not in the most updated version. Because, just now I submitted and it’s working from my side.

With regards,
Nilosree Sengupta

Hello @nilosreesengupta ,
Please find attached the screenshots.
The Upload Document SS shows the page where I am having the issue. The upload bar is visible for a split second. So its impossible to capture that screenshot. Also, please not I am having the same issue for all 4 week’s assignments.
I have also attached a screenshot that contains the uploading file details.


Hello @Avik_Biswas ,

Thank you for attaching the screenshots!

I think you are not presently in the updated version probably.
@Community-Team will be able to help you with this.

With regards,
Nilosree Sengupta

Hello @chris.favila ,

I am tagging you here to let you know this issue. I also a found a similar post here https://community.deeplearning.ai/t/not-able-to-upload-ipynb-and-pkl-files-in-my-submissions-tab/107318

With regards,
Nilosree Sengupta

Hi Avik! Can you try this first::

  1. Go to the My submissions tab, create a submission, and click Replace file for both files.
  2. Select any 2 random files that have different filenames (even different file extensions) but do not click Submit.
  3. Click Replace file again and now select the correct notebook and pickle file.

See if the submit button now turns blue and you can proceed to upload them. This has worked in a previous specialization before and we already flagged it to Coursera as a potential bug. If the method doesn’t work, please let me know. Thank you!

Hi Chris!
Could you please help me locate the Replace file button?

Hi! You can just hover over the files shown in your screenshot. It will show up on the upper right side of the blue button…
Screen Shot 2022-03-11 at 10.10.49 PM

Hi Chris!
The only icon I have on the blue button is the upload icon, I think (as shown below in the screenshot.) Am I missing something?
Button SS

Oh I see. In that case, you can also use that. Click that, then select some random files, then click again to select the correct files. Hopefully, the submit button will turn blue with that.

Hi, Not able to upload any file, I am selecting the file but its not taking the file same thing appears. Tested with other random files, did not work.

Hmm… That is strange. Can you try another browser or in an Incognito/private browsing session? If that is still the case, then it looks like an access issue with your account. I cannot replicate it on my end. I am able to submit files and also got a grade. I am using Google Chrome. Here are my proposed next steps if changing browsers or switching to a private session do not work:

  • Please reach out to Coursera via the Learner Help Center and ask them to unenroll you, then immediately re-enroll you in the course.
  • Here is a template message you can put in the Description of issue field in the Help Center form:

Hi! A new version of Convolutional Networks in Tensorflow by DeepLearning.AI was recently launched, but I cannot submit my assignments. The submit button is always greyed out. Please unenroll, then immediately re-enroll me to the latest version of the course. This has resolved access issues for previous learners and it might also help in this case. Thank you!

Please let me know how it goes! Thanks!

I am using Chrome too and also tried with Incognito and Edge just in case. Nothing helped.
Anyways, have raised a request at Learner Help Center and waiting for a response.

I am facing the same problems. How did you solve the issue?

Hello, I am facing the same issue where I am unable to upload / submit the .ipynb and .pkl file for C3_W4 TF developer. Can someone please advise me how I can complete my course and submission?

Has this been resolved? I am having the same issue…? Has anyone been able to submit? If yes, how did that work?

I’m having the same issue. The submit button is greyed out so I can’t upload the assignment.

This didn’t work for me.