W1 A1 - Error Failed to Execute Submission Request: no additional error text

I am attempting to submit the first assignment, but when I do I just get the message "Failed to Excute Submission Request: " and then no additional error text. I have restarted the kernel a few times, rerun the notebook, gotten a fresh copy, and still no dice. I attempted to submit this morning and failed, gave it a few hours and tried again, and still nothing. The file passes all tests and all code is within the appropriate comment delimiters. Does anyone have any idea what my next step should be? I’m out of ideas.

Are you enrolled in the course via a paid subscription (or via financial aid)?

In addition to Tom’s questions, is this your first DeepLearning.AI course? Did you take DLS Course 1 and were you able to submit the assignments there? The reason I ask is that if this is literally your first course, it’s also a possibility that you are being blocked by some security software on your computer or local area network.

I did take the first course, and I was able to submit all the assignments for that course without issue.

I’m taking this course through Coursera - I accessed it through a work portal of recommended courses but it’s free to enroll.

Maybe Coursera staff would help you with this. Here is the guide on how to contact them.

In addition to Saif’s suggestion of contacting Coursera support, there may also be some misconfiguration of that course on the work portal that you mention. You might want to ask your IT support people at work who deal with the Coursera interface or check to see if any other students at your company have had problems with this course.

I’m still not able to submit any of the labs for this course - I’ve completed them, but I get the same error for all of them. I’ve attempted to reach out to Coursera several times but I haven’t heard back. I’m just really not sure where to go from this point.

It sounds to me like maybe you’re not actually enrolled in Course 2 of the DLS.

Please show us an actual screenshot of the error that you are getting.

Did you try my suggestion of consulting the IT people at your workplace and asking if anyone else is having this problem with this particular Coursera course? Can they give you the contact info for another employee at your company who is taking this course and is having it work correctly?

This is the entire error I see - I see it for all programming assignments within the course. Since the course is tracking my progress and grading my quizzes, I don’t see how I could not be enrolled. The IT on my end has indicated they just connect my work email address Coursera account to their own internal tracking systems - they don’t actually do anything other than receive updates from Coursera about what I’ve completed, and create a webpage with links to the course options they’ve organized (and in come cases pre-paid for) so I’m pretty sure the issue isn’t with that. I also successfully completed Course 1 and had no issues with submitting programming assignments then.

Thanks for your very detailed followup on this. I agree this is pretty mysterious. Of course it’s impossible for us to actually see exactly what is happening without being “in your shoes” as it were. My analysis would be that the most likely theory is still some sort of IT problem: the actual web access for “Submit” is probably not just a normal “port 80” URL of some sort and that operation is being blocked by some piece of software in the chain between your browser and the Coursera website. It could be A/V software on your computer or a firewall or proxy server in your local network or a router at your ISP or … Do you or any of your IT folks know how to do packet traces? That would be the way to figure out where in that chain the rejection is happening. Or maybe there’s a “debug mode” in your browser where you can see the actual URL that is being used and the error that it is getting (4xx or 5xx or 6xx or …).

But stepping back one level: are you sure there’s nothing that changed in terms of how you are accessing this course versus the previous one that worked? E.g. different computer, different browser, different department at your company or you’re doing this from home instead of from the office or you updated your version of Windows or ??? There must be something different. Do you have the ability to go back to the previous course and try submitting one of the assignments again? I realize that Coursera cancels your subscription after a while, so that might not be possible. But maybe your company’s setup will let you re-enroll in the previous course. Or try a different one that you haven’t taken yet like DLS C4. But if you could try that and it still succeeds, that would point more to some incorrect setting in a firewall someplace.

This seems very likely to me also.

This theory is also supported by the lack of any similar reports from other learners.

Given that the submit process is managed by Coursera’s back-end, there is very little chance (for legitimate security reasons) that they would explain in detail how it works.

When I go back to the previous course, I’m able to re-submit the programming assignment successfully, which at least rules some things out. As far as I can tell, my access is the same, though I have tried in different browsers and from home as well while troubleshooting, and I get the same error. I don’t know how to do packet traces, and our IT person just went on vacation, but I can ask her when she gets back. Does anyone know of an alternative way to get in touch with Coursera? I’ve submitted the form linked elsewhere twice and haven’t heard back, and our firewall actually does block the chat function. Since there’s a time limit on the course I’d really like to knock it out.

Thanks for trying the previous course again. It’s interesting that it works. I’m not aware of any better way to ping Coursera than the instructions Saif gave above, but I have to say I’m not sure that’s going to help in any case. Tom’s point is the key one: it can’t be a general problem with DLS C2 on Coursera or we’d be hearing about it from lots of students. The issue somehow must have to do either with your account or the system that your company has for registering for the Coursera courses.

Maybe the one other thing we could do is alert the DeepLearning folks to your situation and see if maybe they have some magic levers they can pull with Coursera to get their attention and have them look at your account configuration on their site. I’ll DM a couple of the course folks that we know and see if they know anything to try here.

Hello Bookmeg,

as you have enrolled for free, you will not be allowed to use any of the grader assignments and that is why you are not able to submit the assignment for this course.

When you enrolled for free, you are auditing for the course.

When you audit a course you’ll be able to see most of the course materials for free, but you won’t be able to submit certain assignments or get grades for your work . You won’t get a Course Certificate, but you can pay for one at any time during or after the course.

Hope it helps.



While enrollment was free to me, it’s prepaid through my work, so I’m actually taking the certificate version. I was able to get a certificate for course one, and I’m about to get one for course three.

my reply was for your this response.

have you checked if your course subscription being paid? You can clearly go and check on your Coursera profile under my purchase which will give all payment details related to the course you have done and or being paid.

In this section if it is showing paid, take a screenshot of it and post this issue on Coursera learner help centre with payment screenshot for the course being already paid and asking them why are being not allowed to do assignment grader. You will surely get response from them.


Based on this message, I want to know the work id you are using is your own personal work id or a common work id which other employees can also use?

The image clearly mentions, assignment were already submitted. So unless someone already has not done the assignment, this message should not appear. If your work place is using a same id for all employees to do the course then this problem can occur, as some of lab assignment will have submission limit.

I guess informing Deep Learning QA team is another option where they can also inform coursera from there part, but for that they would require your lab id or email id you are subscribed through for this course.

I am tagging the concerned person for this course, you can also personal DM him with the explanation of your concern.

@Mubsi Can you please check into this issue. Thank you.


Discussion of this topic has moved to a PM thread with Paul and Mubsi.