W4_A1_submission output_ 0/100 when tests were passed

i submitted the first assignment in the fourth week but I keep getting 0/100 multiple times. Please what can I do about this?

Hi Dami,
Thanks for the question, let me see if we can help you. I assume you mean the assignment " Building your Deep Neural Network: Step by Step"? Are you able to share the grader output under my submission?
Regards Stephanus

Yes, that assignment. Sorry, I don’t understand, do you mean I should share the grader input with you?

We are more interested in the output, if you get 0/100 I guess there will be some kind of error message hinting where the problem could be.

In the cousera lab it is showing that all the tests except two were passed. I can’t seem to find a solution to the two cells that are not running as the problem is from the codes that were pre-written in the cells.

Hello @dami

By the output mentors mean this:

you can always click on it and see what is the problem or see which ex are not graded and why


1 Like

Thank you very much @Viktoriia

1 Like

Here is the grader output:

[ValidateApp | INFO] Validating ‘/home/jovyan/work/submitted/courseraLearner/W4A1/Building_your_Deep_Neural_Network_Step_by_Step.ipynb’
[ValidateApp | INFO] Executing notebook with kernel: python3
Tests failed on 10 cell(s)! These tests could be hidden. Please check your submission.

The following cell failed:

parameters = initialize_parameters(3,2,1)

print("W1 = " + str(parameters["W1"]))
print("b1 = " + str(parameters["b1"]))
print("W2 = " + str(parameters["W2"]))
print("b2 = " + str(parameters["b2"]))


The error was:

NameError                                 Traceback (most recent call last)
<ipython-input-3-3984a613433b> in <module>
----> 1 parameters = initialize_parameters(3,2,1)
      3 print("W1 = " + str(parameters["W1"]))
      4 print("b1 = " + str(parameters["b1"]))
      5 print("W2 = " + str(parameters["W2"]))

NameError: name 'initialize_parameters' is not defined

The following cell failed:

t_AL, t_Y_assess, t_caches = L_model_backward_test_case()
grads = L_model_backward(t_AL, t_Y_assess, t_caches)

print("dA0 = " + str(grads['dA0']))
print("dA1 = " + str(grads['dA1']))
print("dW1 = " + str(grads['dW1']))
print("dW2 = " + str(grads['dW2']))
print("db1 = " + str(grads['db1']))
print("db2 = " + str(grads['db2']))


The error was:

KeyError                                  Traceback (most recent call last)
<ipython-input-20-3ace16762626> in <module>
      1 t_AL, t_Y_assess, t_caches = L_model_backward_test_case()
----> 2 grads = L_model_backward(t_AL, t_Y_assess, t_caches)
      4 print("dA0 = " + str(grads['dA0']))
      5 print("dA1 = " + str(grads['dA1']))

<ipython-input-19-5ca0c1741e70> in L_model_backward(AL, Y, caches)
     41     current_cache = caches[L-1]
---> 42     dA_prev_temp, dW_temp, db_temp = linear_activation_backward(grads["dA" ...
     43     grads["dA" + str(L-1)] = linear_activation_backward(dAL, current_cache,...
     44     grads["dW" + str(L)] = linear_activation_backward(dAL, current_cache, a...

KeyError: 'dA4'

Hello @dami

Regarding the error with dA4, please make sure that you are looping through correct indices.

regarding grads, please make sure you are passing correct arguments.

1 Like

It is strange, the first error seems to be implying that your initialize_parameters function has not been defined. Did you get the right results when executing the cell in the Jupyter notebook?

NameError: name 'initialize_parameters' is not defined
1 Like

That particular cell did not execute at all because of the error @albertovilla

@dami was it working when you executed it in the juypter notebook? I mean prior the submission of the notebook. If it worked when you were executing it interactively then it could be an issue with the grader as suggested by @Mubsi, however, he is referring to course 4 and this is an issue in course 1.

whoops, haha, my bad :3

No @albertovilla it was not working at all

So what is the error when you execute the initialize_parameters cell in Jupyter?

I have exactly the same problem, can you tell me how you solved the problem,please?

Which problem? The grader 0/100 problem or the initialize_parameters not defined problem?

If it’s the latter, you probably just forgot to run the earler cells in the notebook. Try “Cell → Run All Above” and then run the failing cell again. Note that you have to do that every time you close and reopen the notebook. There is a topic about that on the DLS FAQ Thread.

BTW This thread is almost 2 years old. You will generally have better luck opening a new thread rather than tacking onto an old one, even if the topic is similar.

1 Like