Week 3 assignment 2 - dead kernel

Thank you for your feedback. But we are just volunteers, not Coursera staff. They handle all these environment things…

Got it. What’s the best way for me to give them feedback?

Tom submitted an issue about this.

1 Like

I’ve encountered the same dead kernel issue as @Marc_Shepard, except my Jupyter notebook hangs immediately after printing Epoch 1/5.

After reading through this thread, I successfully submitted the assignment and received the grade expected. However, I would really like to finish the assignment and see the model in action. Has there been any progress on this issue?

Yes, the “dead kernel” issue was fixed a few weeks ago, when Coursera increased the amount of memory the GPU array could use.

So I am surprised by your report.

I’ve tried running it again today, at 11:30am UK time (before 6:30am for all of the US, when I assume the majority of Coursera users will be sleeping), and it has worked on the second attempt. Perhaps the time of the day makes a significant difference.

Thank you. :slight_smile:

Thanks for the report. I’ve raised the issue for course staff to be aware.

C4 W2 A1. Kernel error during Resnet training still persists and it is very frustrating.

I get the dead kernel error at the exact same point. Frustrating.

The best current guess about this issue is that it depends on how busy Coursera’s servers are. Given this is a weekend day, that might be the case.

Maybe try again in a few hours.

Another thing you can try is to use “Kernel → Restart and clear output”, followed by “File → Save and checkpoint”, then use Submit without running any of the cells.

After several restarting of kernels, I got past the Epoch 1/5 and finished the task. Thanks for your help!