Week4 - Assignment submission error

After completing the last assignment, I submitted it 12 hours ago. Since it still did not update the status, I refreshed the lab session and tried to resubmit. I get this error now

Failed to execute submission request: HTTPSConnectionPool(host=‘hub.coursera-apps.org’, port=443): Max retries exceeded with url: /api/workspaceSubmissions.v1?action=createBatch (Caused by SSLError(SSLError(“bad handshake: SysCallError(-1, ‘Unexpected EOF’)”)))

I am seeing this error for the first time. @Mubsi check it out…

are you using a proxy setting or work/office system?

Please check this SSLError HTTPSConnectionPool(host='www.coursera.org', port=443): Max retries exceeded with url: /api/login/v3 · Issue #661 · coursera-dl/coursera-dl · GitHub

Might help you.


No, I am home on Windows 10 with Chrome. The same browser I used to complete all the assignments of this course and of the Machine learning specialization track.

Hi @Shailendra_Majmundar,

Close your assignment and open it again using the “open” assignment button. Then try submitting.

If it persists, log out of coursera, log in and then try again.

If it still remains, let me know.


Hi @saifkhanengr,

I believe I have seen it many times before. Trying to submit after a bit usually works.


Hi @Mubsi
It worked.
Thank you!