In the week one lab I tried consuming my service and followed the instruction. the instruction says we can’t access it using the http but from the navigation bar but when I try it shows me 502 error.

how can I rectify this issue.

Hello @Nnaemeka_Nwankwo
Try to:
Refresh the Page
Clear Browser Cache
Check Network Connectivity eg firewall restrictions, misconfigured network settings…

Let me know if it works

Probably you stopped server application. Just start it and try again.

I thank you so much guys. I got the message “Congratulations! Your API is working as expected.” sorry I am just replying to messages. It has been a few rough weeks, but I am glad I am back. one more question as regards the fastAPI integrated client to see it working what must I do next? in other to get to this part in the image below the instructions are not so clear to me.

Hello, I did it on my local system and I got the response “Congratulations! Your API is working as expected" but I want to know what next to do as regards Instructions to use the client API I don’t understand the instructions please If I can be guided or the instructions clearer I would be very glad.
Kind regards.

Hello @Nnaemeka_Nwankwo

Congratulations on successfully deploying a model with FastAPI!, Now you can start doing Inference/making predictions with the deployed model.

GET Requests : is typically used for retrieving information from the server

POST Requests: is typically used for sending data to the server, such as making predictions or performing actions that require a payload in the request body.

How to use:

  • Structure the data that you’ll send to your API endpoint using JSON format
  • send the POST request to the server.

Here is an example of a JSON format:
“fixed_acidity”: 7.2,
“volatile_acidity”: 0.3

Replace the values with the specific data


thank you so much @Isaak_Kamau for the help. I am now trying to rerun my notebook locally again it is showing

me this error but I previously used it. should I downgrade or set protocol?
kind regards,

Thank you so much @vigen I got the congratulatory message. But now, I tried re-running the notebook and I am getting an error.
PS- I am running the notebook on my local machine.