C1 W1 Ungraded Lab: Error 400 Bad Request

I tried following all the instructions on the server.ipynb and I’m successfully able to launch the server but once I upload an image for testing the model, I get a 400: Error Bad Request response from the server.

Hi @saireddythfc! Welcome to discourse!

Ohh that is strange, did you uploaded one of the images provided in the lab or one of your own?

Also, can you try running the code in the client.ipynb notebook and let me know if it works there?

Finally, can you copy the contents of the requirements.txt file that you are using? We updated those libraries recently so maybe there is a problem there.

Thank you! :slight_smile:

Thanks for responding @a-zarta.
Yes, I used the image provided in the lab itself.

Whilst running the client.ipynb, I came across the following error: “ConnectionError: (‘Connection aborted.’, RemoteDisconnected(‘Remote end closed connection without response’))” when I tried to open a file in my filesystem and pass it as a parameter alongside the URL.

Here are the contents of requirements.txt:

Hmm I see :thinking:

You are def using the latest version of the lab. Looks like a networking issue to me. What OS are you using to run the lab? Also which method are you using (Docker or virtual env)?

I am using Mac OS (Big Sur 11.1) and I have used Docker.

Sorry for the late response, I was on break.

In that case can you try running the lab with the conda environments method? This way we can know if there is some issue with the networking settings in your Docker configuration.