C1_W2_Assignment - problem Importing Functions and Data

I get this error message:
[nltk_data] Error loading twitter_samples: <urlopen error [Errno -3]
[nltk_data] Temporary failure in name resolution>
[nltk_data] Error loading stopwords: <urlopen error [Errno -3]
[nltk_data] Temporary failure in name resolution>

Any ideas how to resolve - I am using the standard Jupyter notebook - worked ok yesterday when I started!

I have fixed it now - refreshed assignment and rebooted via the lab help function

It’s good to hear that you found a solution. But if it worked yesterday, somehow some files must have gotten deleted between then and your “Refresh” operation. It’s a little scary to think that there is some gremlin in the server infrastructure that’s going around and randomly deleting files in various Docker images. But they do have mechanisms for propagating updates to the assignments, so I guess anything is possible there.

It’s not a bad idea to protect yourself against random server malfunctions by keeping local backups. You can download just the notebook itself by clicking “File -> Download as notebook (ipynb)”. Just on general principles, there is also a topic on the DLS FAQ Thread about how to download all the files associated with any assignment. There are a fair number of topics there which are not DLS specific.