C1W1 Pip Install Error

Hello,

I tried to install with the Conda environment as recommended and am getting many errors as shown in the plots below. Could someone send an updated requirements.txt file that will work?

The first error occurred using the initial requirements.txt file. The second error occured after I removed the version for the opencv-python-headless package.

hi @ben.spivey ,

I see there is a warning about an old version of Python. Can you check which Python is active in the environment?

which python should show it.

The expected version is 3.7.

Cuong

1 Like

Hi, Can someone explain why i see this error message please ?
Where is should insert the requirements.txt file please ?

@Alfredo_Cappelleri See here: machine-learning-engineering-for-production-public/course1/week1-ungraded-lab at main · https-deeplearning-ai/machine-learning-engineering-for-production-public · GitHub

It says “Before proceeding, double check that you are currently on the week1-ungraded-lab directory,”. But you are currently in C:\Users\alfre.

And towards the end of the Introduction it was explained how to get to the correct directory: machine-learning-engineering-for-production-public/course1/week1-ungraded-lab at main · https-deeplearning-ai/machine-learning-engineering-for-production-public · GitHub

It says " The cd command allows you to change directories. Assuming you are at the directory where you issued the cloning command, type the following on your terminal."

cd machine-learning-engineering-for-production-public/course1/week1-ungraded-lab