C2W2_Assignment MLOps Score not working

C2W2_Assignment MLOps Score not working it always gives strange kind of errors

Example Gen
There was a problem compiling the code from your notebook. Details:
‘NoneType’ object has no attribute ‘outputs’

Please click my name and message your notebook as an attachment.

I am having the same problem and is messaging Balaji.

Hello @balaji.ambresh I am somehow pretty confident that the C2W2_Assignment I have produced out there is correct, however, when submitting the assignment it always prompts Grade Received 0%. Isn’t there any chance the grader is not performing as expected under my account? I am happy to share with you the notebook .ipynb (due to policy of not sharing the code I have cropped the screenshot, but in essence all of the error provided under the Example_Gen have been provided).

Please click my name and message your notebook as an attachment.

Please refresh your workspace and run the cell containing the code below before coding rest of the assignment:

!python add_metadata.py --filename C2W2_Assignment.ipynb

I’m having the same problem with this output that I can’t suspect

See the incorrect closing bracket placement when creating tfx.components.StatisticsGen( in cell with execution number 26. You’ve repeated the same mistake in the next cell as well. This is something that should have been fixed before submitting to the grader. Good luck.

I have fixed that, but I still have the same problem, when I submit I still get, even everything is working when i run the cells

Please click my name and message your notebook as an attachment.

Look at cell with execution number 65. You’ve made a compilation error there in creating tfx.components.StatisticsGen.

Please help me understand the following:

  1. Why submit invalid notebooks to the grader?
  2. Why is the notebook modified after all cells ran to completion?
  3. Level of comfort in programming. With all respect, this is an advanced level specialization. Not knowing the basics of programming and not correcting mistakes based on feedback from within the jupyter notebook environment will get in the way of completing the labs.

I know that error, but I can’t write in notebook cell, what you advice me to do ?

Please follow these steps to refresh your workspace

If a cell you cannot edit is throwing an error:

It most likely means that cell is running a test of some other function that you modified, and your code for that function contains an error.