C3w1 lab create dataset

I believe I got to the following stage but can find where to load data.csv. There is no select csv file on Cloud Storage and I do not see a data.csv on Could Console though it is created:

“student_03_3ee472389904@cloudshell:~ (qwiklabs-gcp-03-fa81eff29e69)$ gsutil cp gs://spls/gsp223/data.csv .
Copying gs://spls/gsp223/data.csv…
/ [1 files][ 2.5 KiB/ 2.5 KiB]
Operation completed over 1 objects/2.5 KiB.”


Choose Select a CSV file on Cloud Storage and add the file name to the URL for the file you just uploaded - gs://your-bucket-name/data.csv

An easy way to get this link is to go back to the Cloud Console, click on the data.csv file. Click on the copy icon in the URI field.

Hi Kevin! Are you using multiple windows for this lab? Or did you happen to reload the current page or used the Back button? I found that this sometimes cause the chosen account to switch. Please click on the profile icon on the upper right and check that you’re still using the student credentials given. It’s possible that GCP automatically switched you to your personal gmail account. This is usually the issue when I encounter missing files or permission errors in these labs. Hope that is also the fix in this case.

Also when you go to Cloud Storage, do you see the data.csv in the display? If so, there might be a checkbox beside it and when you tick it, an option to copy its URL will be available.


I am having problems with all these labs not working right. I went into incognito and tried to do the lab there. for the canary testing C4w3. I got the first part but for the deployment is failing. I have ‘K’ instead of ‘S’ as a student. Not sure if that is the problem. The following is my config which should be correct.

apiVersion: v1

kind: ConfigMap

metadata: # kpt-merge: /resnet50-configs

name: tfserving-configs # resnet50-configs


MODEL_NAME: image_classifier

MODEL_PATH: gs://qwiklabs-gcp-01-194ee3444867-bucket/resnet_50

Hi! I am sorry to hear that. Kindly share or screenshot the exact error message you see because that might help resolve the issue. Thanks!

I think I am going to finish the course and then go back to lab one and start from there. With the exception one all have problems, sometimes I can even get back to where I got before.

Copy. Thank you for the note. Remember to include error messages and/or screenshots so we can have more context while troubleshooting. Also, as mentioned before, make sure that your account is not inadvertently switched by starting a fresh Incognito session. Qwiklabs might give you different sets of credentials each lab so it’s best to close previous Incognito sessions to make sure that old ones don’t linger in your system. Thanks again!

Hi Chirs,

So I have gone back to the labs and am doing C3W4 trying to use what_if tool and the problem for creating a new instance for a notebook persists with an error, I have attached a screenshot.

Actually ignore the last email with regard to c3w4 lab finally came on after many trials.
Thanks will move on to the next lab now

Hi Chris,

I am on the lab tfx google cloud AI platform pipelines and I am on the last section which says
"Click on the Trainer component in the KFP UI once it is running and navigate to the Visualizations tab. "

But I find no “Trainer” component unless I am on the wrong KFP UI , I attached the page that I am on which I believe it to be KFP UI, same as “experiment” but seems I am in the wrong place.

Hi Kevin. It should be in the Runs page instead of Experiments. Previously, there is a bug in the Visualization of Tensorboard and I’m not sure if the Qwiklabs team has fixed it yet. Will follow up. If you don’t see it, don’t worry about it for now since you can complete the assignment without it. It will just look like the Tensorboard output of some labs in Course 3.

Hope this helps. For next time, please post a new topic in the related course so other mentors or learners can help. I believe this query should be filed under Course 4. Thanks!