C4-Week3: Anyone experiencing an issue with the grader?

I am receiving this error after submitting my homework:
" * ### Grader Error: Grader feedback not found

Visit the Discussion forum to see if your peers are experiencing or have found resolutions for similar errors. If the error isn’t resolved in 24 hours, please reach out to Coursera through our Help Center"

Hi @fjpicaso,

At the start of the notebook there’s:

Important Note on Submission to the AutoGrader

Before submitting your assignment to the AutoGrader, please make sure you are not doing the following:

  1. You have not added any extra print statement(s) in the assignment.
  2. You have not added any extra code cell(s) in the assignment.
  3. You have not changed any of the function parameters.
  4. You are not using any global variables inside your graded exercises. Unless specifically instructed to do so, please refrain from it and use the local variables instead.
  5. You are not changing the assignment code where it is not required, like creating extra variables.

If you do any of the following, you will get something like, Grader Error: Grader feedback not found (or similarly unexpected) error upon submitting your assignment. Before asking for help/debugging the errors in your assignment, check for these first. If this is the case, and you don’t remember the changes you have made, you can get a fresh copy of the assignment by following these instructions.

This clearly mentions if you do any of the listed things you will run into Grader Error: Grader feedback not found.

Please make sure you are not doing any of these listed things.


Hi Mubsi,
I’m not doing anything violating these. As you can see, I’m on my 4th course already so I am pretty much aware of what to do and not to do.

Can you share the screenshot of your error

Hi @fjpicaso,

Makes sense. I’d need to look at your code then. I’ll DM you regarding it.


1 Like

Here it is.

1 Like

Hi @Mubsi @Deepti_Prasad

Im having the same issue. tried 3 times now.

Hi @Anfas,

When you say you have tried 3 times, do you mean your tried submitting the sam assignment 3 times or did you make any changes before each time you submit ?



in the platform error, it tells you to try after 10 mins and raise issue in coursera help centre. Did you raise this issue there too?

Like how Mubsi said, will have to look at your notebook, to know what might have gone wrong!!!

Please send your notebook via personal DM. Click name and then message. If you have send Mubsi, then I guess he will resolve your issue surely.



Hi @Mubsi,

I did not make any changes. Since there were errors in the grader, I tried subsequent times. Each time, I got the same error.

Hi @Anfas,

Please refer to this then


@Anfas @fjpicaso I’m experiencing the same :confused:

I am experiencing the issue on both homeworks.

I am facing the same error.

Hi Mubshi,

​I flushed the previous workbook and fetched a fresh one; let me try it again.

Hi all,

With all your complains, it seems to look like a platform (Coursera) issue more and more. I have been having trouble with the grader as well now.

What I’d suggest is to try submitting after a couple hours and keep me posted.

I’ll see what I can do on my end.

Thank you for your patience,

Also, getting a fresh copy and starting from scratch could also help solve the issues

Hi All,
It seems a fresh notebook solved it for me.
I got both homework working.

I also tried to refresh but it doesn’t help, I still have the same issue with the first homework.

Hi all,

I have been informed by Coursera that there was a large AWS outage which affected the grading system.

It has been resolved now.

Please try submitting again and if the issue persists, please let me know.