C4W2: Autoscaling Deployments - TF Serving and Kubernetes

I have attempted this lab several times but have yet to be able to provision GKP clusters, step 2. I was able to complete later labs, including ones that involved creating GKP clusters. Sometimes after about 40 minutes I will get an error, other times even after the entire lab time has run out I have not gone past 64% success. I reached out to qwiklabs but after several days of attempts on this lab I cannot make any progress beyond step 2 and I have not received any information about how to complete the course without it.

Here is a sample of my current error, “Quota ‘SSD_Total_GB’ exceeded. Limit: 500.0 in region us-central1”.

I just tried creating the cluster following the instructions and things work.
Please try again and if you can’t pass the lab on us-central1-f or another zone, reach out to qwiklabs help.

Default change: VPC-native is the default mode during cluster creation for versions greater than 1.21.0-gke.1500. To create advanced routes based clusters, please pass the `--no-enable-ip-alias` flag
Default change: During creation of nodepools or autoscaling configuration changes for cluster versions greater than 1.24.1-gke.800 a default location policy is applied. For Spot and PVM it defaults to ANY, and for all other VM kinds a BALANCED policy is used. To change the default values use the `--location-policy` flag.
Note: Your Pod address range (`--cluster-ipv4-cidr`) can accommodate at most 1008 node(s).
Creating cluster cluster-1 in us-central1-f... Cluster is being health-checked (master is healthy)...done.                                                                    
Created [https://container.googleapis.com/v1beta1/projects/qwiklabs-gcp-01-4de941ba27e1/zones/us-central1-f/clusters/cluster-1].
To inspect the contents of your cluster, go to: https://console.cloud.google.com/kubernetes/workload_/gcloud/us-central1-f/cluster-1?project=qwiklabs-gcp-01-4de941ba27e1
kubeconfig entry generated for cluster-1.
NAME: cluster-1
LOCATION: us-central1-f
MASTER_VERSION: 1.27.3-gke.100
MACHINE_TYPE: n1-standard-4
NODE_VERSION: 1.27.3-gke.100

So I have a ticket open with Qwiklabs, opened on July 26th. There is definitely an issue with GCP resources or however the lab is being served to users because no region allows a user to deploy GKP clusters for this lab. It looks like there are other users with similar issues but no resolution yet.

Hi Martin! We just got news from Qwiklabs, and this should now be fixed. I tried it just now and was able to create the cluster:

Hope it also works for you. Thanks!

Hi @chris.favila, hope you’re fine!

Wondering if you could help me with this.

On this step:

To invoke the model set the EXTERNAL_IP environment variable to the external IP of your service and execute the curl command:

I’m getting a curl: (28) Failed to connect to [MY_SERVICE_IP] port 8501: Connection timed out

curl -d @locust/request-body.json -X POST http://${EXTERNAL_IP}:8501/v1/models/image_classifier:predict

It seems I’m unable to properly pass my EXTERNAL_IP, which I’m extracting thru:

curl http://checkip.amazonaws.com/

any thoughts? Thanks!

Hi Ivan. Please revisit Task 6 of this lab. You should be able to get your service IP from the commands there. Then you should manually type it in the command: EXTERNAL_IP=type the IP address here.

Hope this helps.

Next time, kindly create a new topic if your query is different. This will give our mentors the chance to assist, and learners with the same concern will also find it in the forum easier. Thanks.