C4W3 - Graded lab TFX on Google Cloud Vertex Pipelines fails on start


The lab " TFX on Google Cloud Vertex Pipelines" of the week 3 for the course " Deploying Machine Learning Models in Production" fails on start in quicklab.

Here is the error I get after clicking on the “Start lab” button :

Lab failed on Sat, 26 Nov 2022 07:51:52 -0500: Deployment Manager error: On [/deployments/qldm-36885428-4caa68fc6e43467d/resources/startup-vm]: ["{"ResourceType":"compute.v1.instance","ResourceErrorCode":"ZONE_RESOURCE_POOL_EXHAUSTED","ResourceErrorMessage":"The zone 'projects/qwikl… Any credits or tokens you used to start this lab have been refunded.

I talked with the chat support which answered me with :

We’d regret to inform you that there is a technical problem in some labs and a bug is also raised regarding the same. Our technical team is already working on it to get it fixed on priority.We will put our best effort to fix this and get you up and running at the earliest and we’ll get back.

Any Idea when the lab will come back up ?

1 Like

Please ping this topic if you don’t hear from qwiklabs in 48 hours.


Same issue here for the last 2 days. Apparently, there is a platform wide issue. They said they are working on it but don’t know when it will be resolved.

1 Like

@balaji.ambresh still encountering the same issue with the lab but no news from the qwiklabs team…

The second graded lab of the same week (“Implementing Canary Releases of TensorFlow Model Deployments with Kubernetes and Istio”) works just fine on the other hand.

1 Like

I’ve now notified to staff to help out.

Hi everyone! Thank you for reporting. We’ve escalated it to our partners and hopefully, it will be fixed soon. Please watch this thread for updates. Thanks!

I just tried to login but still does not work.

Unfortunately still doesn’t work! If there is a workaround for this problem, it would be more than welcome. I have a hard deadline to finish the course by 1st of December.

Hi everyone! I just tried the lab and it should work now. Just ignore the red box that you see when you first open it. If you click Start Lab, it should be able to provision resources after a few minutes. Hope it also works on your end!

Additional Tip: When you get to running the pipeline , please select us-east1 (or whatever region that was used in the notebook) in the dropdown to see it. Otherwise, the list would be blank.

Hi Chris,
Thanks for your update. I just successfully ran the lab and passed all tests.

1 Like

Awesome! Glad it worked!

1 Like

Yeah, it’s not working again, I’ve been trying for the last couple of days but I still face the same issue

Worked fine for me, thank you for the update !

1 Like

Hi Pedro! Welcome to the community and sorry for the trouble in accessing the lab. Can you take a screenshot of the error you’re getting after pressing Start Lab? Thanks!

I tried one more time and it did work :tada:

1 Like