C5_W3_A2 Fails to save and I lose my work on reload

As title says, the second assignment of the third week continuously fails to save. I have already lost my work for the assignment two times.

Is this a course-wide problem or just my computer?

I’m not aware of any recent issue about file saving.

In general, auto-save is very unreliable. Also, Labs will not save your notebook if the kernel is already busy running some code. Some of the models can take several minutes to complete running.

The best course is to manually do “Kernel → Restart” and then do “File → Save and Checkpoint”. Then wait until the save is complete. There is a text banner at the top of the notebook you can monitor.

In addition to Tom’s detailed explanation, I actually tried saving my version of that Trigger Word assignment and it worked fine for me. So whatever the issue is, it’s not system-wide.

Since this is C5 W3, I assume you did not have problems on the earlier assignments. So if nothing has changed in your environment (e.g. different network), then we’d have to theorize that the problem is “bad weather in the Cloud”.

Thank you for the replies, I will try it again today.

I did try to re-start the kernel and save manually, but those didn’t work either. Even the auto-grader failed to grade me and was returning 0/100, stating some error about not being able to access.

As you two said, it must be on my side or the cloud side.

After trying again today, I’m getting the same problems. I restart the Kernel and try to save manually, but it is not saving. I have checked that no cell is running. And the autograder returns me a 0/100 with message:
Cell #25. Can't compile the student's code. Error: TypeError('cannot unpack non-iterable NoneType object')

Which is weird because all cells pass the tests in the assignment itself. At the very least, I don’t think all the exercises are wrong so that I get a 0/100 in the grader.

Edit 2:

As soon as it came, it solved by itself. I don’t even know what happened, but without touching anything else it’s now working again and it allowed me to save and submit properly.

Thank you for the help.

Glad to hear that the issue resolved, so it must have been on the server side.

The explanation for the grader error about “NoneType objects” is that the grader sees the saved version, not your current online version. So if you can’t save, then it’s seeing an unmodified notebook full of the “None” placeholders.

The other point about how the grader works is that it will give 0 for everything if it encounters a python syntax error parsing the notebook. In that case it doesn’t get far enough to actually test any of the individual functions if it can’t even run the notebook.