C5W2 Emojify: Cell #13. Can't compile the student's code. Error: ValueError('matmul: Input operand 1 has a mismatch in its core dimension 0, with gufunc signature (n?,k),(k,m?)->(n?,m?) (size 1 is different from 2)',)

Hello, standard question here. I already checked this:

And the answer you are giving is “the code has errors that weren’t caught by unit tests”.
But then how am I supposed to figure out where the error lies exactly? Is it only in the exercise 5? Is it in some earlier code that’s used in ex. 5? It is quite hard to find out on your own since a lot is abstracted away.

First, it’s a good idea to check a few basic items:

  • Did you save the notebook before you submitted it for grading?
  • Did you complete the entire notebook before submitting it for grading?
  • Did you restart the kernel and clear all the output, then run all the cells and check all the outputs carefully to be sure there are no asserts or incorrect results?

After that, if it appears that the unit tests maybe didn’t catch all of the errors, the mentor will ask the student to download their notebook and sent it via a private message.

Then we can determine whether the unit tests need to be improved.

Did all of that, still getting the exact same error.

Were you able to get the assignment submitted?

Yep, thanks a lot! After applying your fixes everything worked.

OK, that is very good news. I have raised an issue with the course authors and it’s being researched.