"ChatGPT Prompt Engineering for Developers" chatbot hangs

I tried to replicate the chatbot notebook on my computer. It works identical to the version in the course until the actual chatbot cell, which leads to hanging. The UI is shown (textfield and button “Chat!”) but when I enter a text and press the button, the rotating waiting sign appears (like in the course) but does never go away and no answer is given (see screenshot). I am using a valid openAI key (and all cells above give correct answers)

Any idea how I could proceed?

Kindly move this post to the Chatgpt prompt engineering for developers category as posting in the wrong category may decrease the chances of your post being noticed by our mentors.

You can change the category by clicking the pencil icon on the right side of the title, as shown in the below image.


1 Like

I had the same problem when I used Jupyter lab, but it works when I use Jupyter notebook

using jupyter notebook solved it! Would be great though if it worked also in jupyter lab. Any comments from @OpenAI or @deeplearningAI ?