Constraints in Programming Assignment Week 3, Course 1

I submitted the assignment many times but cannot pass. The feedback I got is “Grader timed out”. I don’t know how much time I must be achieved, so I just suggest that the assignment should be added more description about the condition of time and memory usage, such as:

Time limit: 110 seconds
Maximum Memory: 100MB

Having this information, I can have a better plan to pass the assignment. I saw many problems in Competitive Programming that have the condition of time and memory.

The constraints are well specified:

  1. Max number of epochs.
  2. Number of Conv2D and MaxPooling2D layers
  3. Desired accuracy to stop training.

So, where are you stuck?

1 Like

My code is satisfied all 3 constraints:

  1. Number of epochs in 20.
  2. I only added a single Conv2D layer and a single MaxPooling2D layer.
  3. Adding a callback object to with the accuracy 0.998.

This is my output when calling The total running time is 93 seconds.

Epoch 1/20
60000/60000 [==============================] - 16s 265us/sample - loss: 0.1432 - acc: 0.9580
Epoch 2/20
60000/60000 [==============================] - 13s 215us/sample - loss: 0.0465 - acc: 0.9856 - lo
Epoch 3/20
60000/60000 [==============================] - 13s 215us/sample - loss: 0.0278 - acc: 0.9912
Epoch 4/20
60000/60000 [==============================] - 13s 213us/sample - loss: 0.0176 - acc: 0.9946
Epoch 5/20
60000/60000 [==============================] - 13s 215us/sample - loss: 0.0114 - acc: 0.9964
Epoch 6/20
60000/60000 [==============================] - 12s 205us/sample - loss: 0.0096 - acc: 0.9965
Epoch 7/20
59648/60000 [============================>.] - ETA: 0s - loss: 0.0061 - acc: 0.9982
Reached 99.8% accuracy so cancelling training!
60000/60000 [==============================] - 13s 215us/sample - loss: 0.0061 - acc: 0.9981

My submission on Coursera page.

I cannot share my code because of violations.

I just changed some hyperparameters in the first conv layer and the third fully connected layer, so the total running time reduces to 93 seconds. I updated the output above. However, the grader still shows “Greader timed out”. I submitted at 9:54 PM +07, and got the error at 10:14 PM +07. It looks the same as my previous submissions.

1 Like

Seems like you’re using too many kernels in the Conv2D filter or too many units in the 1st Dense layer after the Flatten layer.

See this lecture to get an idea for your hyperparameters.

1 Like

I tried your advice. I reduced the number of kernels, which is less than 64, reduced the number of units in the Dense Layer. But I got the running time is larger, it is 128 seconds, and I cannot pass the assignment.

I saw many similar questions in Discussion forums on Coursera platform, but no staff reply. By using the same config, someone is passed, someone is not. So I think it is the problem from the assignment that is not well defined. I don’t know what constraints I must have in order to get a grade.

I agree with your point that the configuration of layers is not defined.

Could you message your code to me? Click on my name and send me a message. I’ve completed the assignment.

1 Like

Thanks for your help. One of staffs had read this topic and run the grader on my latest submission again. So my assignment is passed.

I think it is the problem of Coursera grader. The running time of my latest submission is longer than the average of my all submissions.

1 Like

Cool. Thanks for the update.

1 Like

I am actually having the exact same problem as hungaya on this assignment. I only have one convolution layer and pooling layer, and the training exits when the accuracy hits 99.8%. I also have submitted it multiple times but cannot get it to pass.

Hi All,

I am also running into this exact error when tyring to submit this assignment.

My network topology is the same as @hungaya , working within all the constraints presented in the assignment.

Eager to find a solution to this if anyone has any thoughts?

All the best,


I’m facing the exact same issue. Should I just wait, or try to contact the staff or support?

One would hope this forum is monitored and they will notice there are many students running into this error! :man_shrugging:

1 Like

Yeah, I hope it is!! I should maybe wait for a day or two

I have the same error , wish any one of the staff could help me to solve it

Running into the same problem. Any staff, please, we need your help!

I also face grader issue when submitting week 4’s lab assignment, even though my code result satisfies all the criteria.

Even I am facing the same issue, though all the criteria has been satisfied.
Kindly help on this issue.

reported this issue to coursera help centre. The representative asked me to try a few troubleshooting options. I’ve tried all but the grader issue still exists. The representative told me he/she has escalated it to their technical team.

Just to update everyone - I just tried resubmitting and passed without the error.

Might be worth everyone trying once more!

All the best,


Is your model configuration have similar number of units to that of the video?

yes, I have made sure I meet the model specifications