ERROR: No matching distribution found for tensorflow==2.2.0

Hello Chris @chris.favila,

Sorry troubling you again.
I followed instructions of downloading Jupiter with python3

I opened by assignment notebook

the first cell to download !pip install tensorflow==2.2.0 fails. I get the below error log

ERROR: Could not find a version that satisfies the requirement tensorflow==2.2.0 (from versions: 2.12.0rc0, 2.12.0rc1, 2.12.0, 2.12.1, 2.13.0rc0, 2.13.0rc1, 2.13.0rc2, 2.13.0)
ERROR: No matching distribution found for tensorflow==2.2.0

How do I solve this issue :slight_smile:

Thank you

Hi @Deepti_Prasad

The latest requirements for running TensorFlow are documented in the installation documentation.

  • TensorFlow only supports 64-bit Python
  • TensorFlow only supports certain versions of Python (for example, Python 3.6 is not supported)

So, if you’re using an out-of-range version of Python (older or newer) or a 32-bit version, then you’ll need to use a different version.

I hope this help.

Best regards

Hello Elirod,

Yes I came across a post about same by @James_J_Johnson. he mentions we need to use python 3.8 version, so one need install and do the assignment and then uninstall. So I was wondering, do I need to uninstall my current version of python first and then do what he has mentioned. Also I am using a MacBook, so will there any issue with the version of python to be used for this assignment for me. I am using Chrome browser for this course assignments. Sorry it might be silly doubt but these version part I don’t have much understanding :grimacing:

Updated hey I just followed your link, it shows software requirement for python as 3.8-3.11, mine is 3.11. So it should work right??

Thank you replying

MacOS and Linux distributions have this odd requirement to run python code. Sometimes you have to digit python3 to execute a installation.

To be honest, i am not quite sure if it is the case here.

Are you using homebrew to install python?

Hi Elirod,

The link you sent, for macOS it shows to install miniconda which is not requirement if for running TensorFlow on CPU. so I ignored this step

then next step it states to create a conda environment

conda create --name tf python=3.9

I need to use this in my python terminal from I believe, and I got output as command not found:conda

I tried with my version of python which 3.11.3
that also states the same :frowning:

how to resolve this??

Yes I had downloaded from homebrew!!

is that the problem??

Yep! the virtual env may cause this issue.

When you install a conda or pip environment, this environment keep the version of your installation.

That means that you have two options: install python/pip on a global environment or on a specific environment.

Just to make sure, are you using conda or other environment on your Mac?

Well if you are using home brew, that’s mean that your python and pip are installed on a global environment

Yes yes they are installed :slight_smile: then why do I have still this issue :frowning:

try to use pip3 comand instead of just pip

Looks like there is a issue with this particularly version of TensorFlow.

There is some requirements in your projects to install this particularly version?

I’m try to install and had the same error.

But, if a try to install the latest version, no error occur

I search for some other issues related and notice that most people are using a Python 32bits version.

Could you confirm if it is your case?

Python 64 bits version

Thank you.

So, i found some treads related to this issue and looks like it is a issue with this particularly version.

Some users report this issue a while a go, but i am wasn’t able to find out if the issue was fixed.

One more thing, make sure that your pip version is grater then 19 by running
python3 -m pip install --upgrade pip.

If the issue persist even with all this steps, so, maybe you have to try another version of tensor flow or try to use google colabs to use this particularly version.

In the mean time, i will do some tests in my Linux computer in order to find out a workaround.

So sorry, for not able to help right now.

Best regards


I did this too,

I cleared all the prerequisite based on the link you sent other than conda environment, which I think it is not required for me as I am latest version of python3.11.3 (if I am correct)

Thank you for your valuable time and effort, appreciate !!!


1 Like

Hi Elirod,

I have a doubt, from what I understood tensorflow==2.2.0 is required to use tensorflow.js

what I noticed in my system tensorflow version is 2.13.0 and I was able to download tensorflow.js

so will I still have issue with the assignment.

All it ask if my local directory has Matplotlib, scipy, which I have.

I am able to do the assignment in the Jupiter notebook, only think I am worried is my model will pass the grader still ??

I am confused :frowning:

Hopeful :crossed_fingers:

It is possible that the grader found a conflict with tensorflow versions.

In order to run properly, i would recommend to use google colab environment to prevent this kind of issues.

actually for this particular assignment, it mentions to use Jupyter notebook, so I am not sure if I am allowed to use google Colab for this assignment.

I have done my model training, converting to js

Lets see if I pass the grader

Oh. OK. I got it now.

So sorry for my misunderstanding.
I thought that you was trying to run the code locally for experiment purposes, didn’t notice that it was a assignment requirement.

Well, i think you can give a try

It failed at the conversion :joy: :face_with_hand_over_mouth:

gave this error
WARNING:root:Failure to load the custom c++ tensorflow ops. This error is likely caused the version of TensorFlow and TensorFlow Decision Forests are not compatible. Full error:dlopen(/Library/Frameworks/Python.framework/Versions/3.11/lib/python3.11/site-packages/tensorflow_decision_forests/tensorflow/ops/inference/, 6): Symbol not found: __ZNKSt3__115basic_stringbufIcNS_11char_traitsIcEENS_9allocatorIcEEE3strEv

I need to have tensorflow 2.2 version

hey can I download in sudo lib this version? @James_J_Johnson

Hi @Deepti_Prasad
I run a couple tests on my conda environment and faced the same issues.

Looks like it is some issue with the pip repository