Facing issues with dependencies in C3W2

Here is the code:

And the error:

RuntimeError Traceback (most recent call last)

RuntimeError: module compiled against API version 0x10 but this version of numpy is 0xf


ImportError Traceback (most recent call last)

[<ipython-input-9-58c818709b7f>](https://localhost:8080/#) in <cell line: 12>() 10 11 # import module for building the detection model ---> 12 from object_detection.builders import model_builder 13 ### END CODE HERE ### 14


9 frames

[/usr/local/lib/python3.10/dist-packages/object_detection/builders/model_builder.py](https://localhost:8080/#) in <module> 32 from object_detection.core import balanced_positive_negative_sampler as sampler 33 from object_detection.core import post_processing ---> 34 from object_detection.core import target_assigner 35 from object_detection.meta_architectures import center_net_meta_arch 36 from object_detection.meta_architectures import context_rcnn_meta_arch

[/usr/local/lib/python3.10/dist-packages/object_detection/core/target_assigner.py](https://localhost:8080/#) in <module> 52 from object_detection.core import standard_fields as fields 53 from object_detection.matchers import argmax_matcher ---> 54 from object_detection.matchers import hungarian_matcher 55 from object_detection.utils import shape_utils 56 from object_detection.utils import target_assigner_utils as ta_utils

[/usr/local/lib/python3.10/dist-packages/object_detection/matchers/hungarian_matcher.py](https://localhost:8080/#) in <module> 17 18 import numpy as np ---> 19 from scipy.optimize import linear_sum_assignment 20 21 import tensorflow.compat.v1 as tf

[/usr/local/lib/python3.10/dist-packages/scipy/optimize/__init__.py](https://localhost:8080/#) in <module> 403 404 from ._optimize import * --> 405 from ._minimize import * 406 from ._root import * 407 from ._root_scalar import *

[/usr/local/lib/python3.10/dist-packages/scipy/optimize/_minimize.py](https://localhost:8080/#) in <module> 24 from ._trustregion_krylov import _minimize_trust_krylov 25 from ._trustregion_exact import _minimize_trustregion_exact ---> 26 from ._trustregion_constr import _minimize_trustregion_constr 27 28 # constrained minimization

[/usr/local/lib/python3.10/dist-packages/scipy/optimize/_trustregion_constr/__init__.py](https://localhost:8080/#) in <module> 2 3 ----> 4 from .minimize_trustregion_constr import _minimize_trustregion_constr 5 6 __all__ = ['_minimize_trustregion_constr']

[/usr/local/lib/python3.10/dist-packages/scipy/optimize/_trustregion_constr/minimize_trustregion_constr.py](https://localhost:8080/#) in <module> 3 from scipy.sparse.linalg import LinearOperator 4 from .._differentiable_functions import VectorFunction ----> 5 from .._constraints import ( 6 NonlinearConstraint, LinearConstraint, PreparedConstraint, strict_bounds) 7 from .._hessian_update_strategy import BFGS

[/usr/local/lib/python3.10/dist-packages/scipy/optimize/_constraints.py](https://localhost:8080/#) in <module> 6 from ._optimize import OptimizeWarning 7 from warnings import warn, catch_warnings, simplefilter ----> 8 from numpy.testing import suppress_warnings 9 from scipy.sparse import issparse 10

[/usr/local/lib/python3.10/dist-packages/numpy/testing/__init__.py](https://localhost:8080/#) in <module> 8 from unittest import TestCase 9 ---> 10 from ._private.utils import * 11 from ._private.utils import (_assert_valid_refcount, _gen_alignment_data) 12 from ._private import extbuild, decorators as dec

[/usr/local/lib/python3.10/dist-packages/numpy/testing/_private/utils.py](https://localhost:8080/#) in <module> 21 from numpy.core import( 22 intp, float32, empty, arange, array_repr, ndarray, isnat, array) ---> 23 import numpy.linalg.lapack_lite 24 25 from io import StringIO

ImportError: numpy.core.multiarray failed to import

I cannot proceed further, please advise.

I can’t answer your question (I’m not a mentor for that course), but I can clean up your post so the comments aren’t shown as Bold Text Headers.

Also, you probably should not post your code on the forum at all. Typically that’s not allowed.

1 Like

I apologize for the inconvenience, and thank you for cleaning my post.
Could you suggest on how should I make the post in order to get help to resolve the issue? I need the solution urgently as I’m working on a tight deadline.

You can only wait for a mentor for that course to notice this thread and provide support.

1 Like

I just ran that assignment and didnt get this error, I am wondering if you have the latest version of it, or if you have changed something above…

Can you check that you have the latest version and if need be reset the assignment!

I reset, deleted the older version and tried with the same code, it had some other error, but running it again somehow worked, and passed. Thank you for the assistance

1 Like