Falied C3_W1_Assignment

Hi , I am facing some issues in the C3_W1_Assignment.
I have submited the Assignment with all correct answers matching with Expected one too but still I am getting Zero points in all exercise.

Error was ‘word_freq_per_class’ is Not defined. but that function also giving correct answer.

I do not understant what is going on

Please help me in this regard

Hi, have you tried re-running all cells from the beginning?

1 Like

I have submited 10 times and still the same issue I am facing

Hi, sorry, I am not referring to submit, but to run all cells from the beginning

1 Like

Yes , I have tried to re-run all the cells rom the beginning too many time , also updated the lab to latest version. still the issue was Not addresed

There are lots of ways you can get 0 points from the grader. So we need more information from you.

What feedback do you get from the grader?

To see this, open the “Grades” tab, select your most recent grading results, and click on the > icon next to each function. This will display the grader’s report for each function.

Please post screen capture images here.

Two questions, please answer both:

  1. Have you completed the entire notebook?

  2. When you run the notebook, does it pass all of the tests and give all of the expected results?

For Every Zero points , I am getting same feedback : name ‘word_freq_per_class’ is not defined. Each and every cell is running successfully with expected results but the final points zero

  1. Yes, I have completed entire notebook
  2. Yes, Passed all of the tests with all of the expected results

But the pionts are NOT given to any one of the results.

if it is possible, I will share .ipynb file for reference


I believe the metadata in your notebook for the graded cells may have been deleted.

This makes the grader crash when it tries to find that function, but cannot because the required metadata was not found.