How to download Week 2 Assignment 1?

The terminal is weird (no command is working) and if I try to download files one by one…the workspace automatically refreshes on ‘resnet.h5’ and I can’t download it.

same, I can’t download the ResNet50.h5 file

I can’t create a zip like the normal way to download my workspace. How do you download?

The file is probably larger than 100 MB.

You need to split the tar archive and then download:

Note: If your zip file is larger than 100MB, you will need to split it up into smaller files instead and download each of them, using the following commands:

  • tar -czf - ~/work | split --bytes=100MB - ~/workspace.tar.gz
  • mv ~/workspace.tar.gz* ~/work/

I answered you in your own thread :slight_smile:

1 Like

@jonaslalin to confirm. There is a problem with the coursera notbook setup. No files show up in the terminal for this assignment. Please confirm that this is the weights file: Google Drive - Virus scan warning
If so, do pass on the feedback to the coursera team to fix the notebook setup. The weights file is 23 bytes in my case.

Have you checked under /tf?

The 23 byte file is a symbolic link. You need to zip and download the actual file, not the symbolic link.

lrwxrwxrwx 1 nobody nogroup   23 Aug 28 17:53 resnet50.h5 -> /tf-ro/W2A1/resnet50.h5

Just did. It’s all there.
Since the weights file is provided with symbolic link, adding -h will get the work done.

tar -chzf - W2A1 | split --bytes=100MB - workspace.tar.gz

Could you please update this page to include the -h flag and also the /tf location for people to look if the terminal doesn’t show the workspace right away?

Thank you.

I will see what I can do.

Note that the Coursera Help Center is controlled by Coursera. All we can do is file a request, but there is no guarantee if or when they will respond. The folks listening here can’t even change the course material (which is the responsibility of, not Coursera) let alone general Coursera things. The /tf pathname is something specific to this course, so Coursera may not want to include that.

Hi @jonaslalin . I used this to create the zip files to be downloaded and it works. However, when I open back file view, it shows W2A1 folder and not /home/work folder. So I need to either open /home/work from file view, or move the zips to /W2A1 folder which from this screenshot is not allowed. Can you help me on how to move to the /home/work folder in file view so I can download the zips?

You need basic linux skills to understand what you are doing. I recommend reading up on basic shell usage and then revisiting this task. You probably need that anyway if you are going to run the labs locally.

Exactly. Also note that “basic shell skills” also includes understanding a reasonable amount about how linux file systems work and how to explore them. E.g. why are you using /tf-ro as the source to copy from? And then why are you copying things into /tf-ro? That is a readonly file system. For this particular exercise, the file system /tf is writable and contains either copies of the files in /tf-ro or symlinks to them (for files that the assignment doesn’t need to change and are large, e.g. resnet50.h5). Your worked notebooks are under /tf, not /tf-ro. But note that the file system name space is not the same on every assignment. That’s another reason you need to understand how to explore file systems in order to succeed at this.

1 Like

@jonaslalin @paulinpaloalto You’re right, yesterday I was just trying to get by and download the files by copying the commands in this thread, modifying here and there and hope that it works. I saw the path “/tf-ro/W2A1/resnet50.h5” in Jon’s earlier reply and auto assumed that as the path to my worked notebooks folder. I am able to move the files to tf/W2A1 now. Thanks for the clarification!

1 Like