How to Fix read-only/unable to save/unable to submit assignment Issue

How to Fix read-only/unable to save/unable to submit assignment Issue

Edit Note: 3 April 2023 (Coursera has informed us that the “permissions issue” has been fixed)


Coursera has informed us that this issue has been resolved. Please get the latest copy of the notebook and let us know if it fixes it. Before doing that, maybe rename the old notebook first.

If you are still having trouble with trying the “get latest solution” above, please comment below letting us know the error you are getting.

And if it works, also let us know then as well.




I have had a chat with coursera support. No surprise there – they thought the issue has been fixed. I had to prove that it is not and provided screenshots in three different browsers. In the end, they have opened another bug ticket. (Internal ticket number: 03807916)

I have asked, what do we do if the issue is not resolved by the time our subscription ends. They urged me to contact them directly if that happens.

So, guys, please keep bugging them until the issue is fixed, otherwise nobody will do anything. Please refer to the ticket number above. Their support chat icon can be found directly on the assignment page. Good luck!

1 Like

I am still having trouble after trying the “get latest solution”

1 Like

Thanks for the fix! I can confirm with the “get latest version” fix I now can save and submit my assignment.


I already did, but they seem to be not trying at all!

I think they have more than one permission bug on the page. One they fixed, the other one is still there.

I have the same impression. I am hoping that quantity of people writing about this, could help the cause.

1 Like

By the way, the issue is fixed just make sure to get the latest version of the lab, I successfully submitted my assignment few seconds ago!

1 Like

Not the issue I am having

Hello. I had the same problem: this instruction helped - thank you!!!
But, I encountered the following problem: Free Up Resources for Other Learners does not work. The “OK” pop-up window does not open, the cells will restart the core. How to fix it?

It works!I have been sad about it for 3days.cry. :sob:

I had some problems with permission, but after April 3rd, I tried the “get the latest version” fix again and it worked for me.

seems to work now with the save, if you go to help on right and reboot and download now notebook:-)

1 Like

the submission work for /notebooks/release/W2A1/Optimization_methods.ipynb as well, cool. I love this course again:-)


Fixed, Rebooting, and reloading to get the latest version help a lot.

Thanks :slight_smile: