Assigment Submission Issue - ReadOnly

The assigment for this week is read-only. I am not able to save or submit my code

I have tried getting latest version, rebooting, clearing cache and different browser but nothing seems to be working with this read-only access.

Hi Salman! I’m sorry for this experience. We’ve already reported it to Coursera and they are looking into it. In the meantime, can you try this and see if you’re able to get a grade?

  1. From the blank notebook, click File -> Open.
  2. Tick the running notebook.
  3. Click Shutdown then Duplicate.
  4. Rename the old notebook (any filename).
  5. Rename the duplicate to the original filename (basically, just remove the -Copy1 string).
  6. Open this newly renamed notebook.
  7. You should be able to save this and also see the submit button after a minute.

You might see an error about checkpoints failing. I think that’s okay because that’s related to the permissions of the hidden .ipynb_checkpoints folder. That is not needed for grading as far as I know.

Hope this works while the fix is ongoing. Please let me know. Thank you!

Hi Chris!
I tried to do what you said. But got this error

Also I tried to create a new folder called “release” but got the same error as above.

Hi Mohammad! Coursera said that the issue should now be fixed. Can you try refreshing your workspace and see if it now works? Thank you!

1 Like

Thanks Chris. But it still doesn’t work! :frowning:

Hi Mohammed. Can you message me your Lab ID? You can click the Help button on the upper right of your lab and find the Lab ID at the bottom of that side panel. Thank you!

@chris.favila I am having the same issue. Is there a fix?


Try to follow the instructions in this post: