Week 2 assignment notebook is read only and no submit button is available

Hello all.
I launched the notebook Programming Assignment: Breast Cancer Prediction from week 2 of the course 2 but I do not see a submit button and also the notebook is read only.
I tried to “Get the latest version” and “Update Lab” following the instructions here to refresh my workspace but that did not resolve the issue.

Please note that when I launched the lab for the first time it mentioned that the instructor added dataset and I just pressed continue to go to the lab (the Change Log shows that dataset was added two years ago though).

Here is a screenshot of the lab notebook:

I also tried downloading the notebook to my local computer, removing the one on the assignment platform and then uploading again from my local computer. This make the submit assignment button to appear and removed the read-only warning. However the save and checkpointing fails on this uploaded notebook. So this may not be a good solution either.

Tried using different browsers, restarting kernel in different ways, etc but problem persists.

I would appreciate your time and help!

Hi Yoones, and welcome to the community! Unfortunately, I cannot replicate the issue. Can you give me your Lab ID so we can investigate further? You can click the Help button on the upper right of the notebook. The Lab ID is at the bottom. Thank you!

Thanks to @chris.favila 's suggested interim solution below I managed to submit my assignments successfully. While we are waiting for the issue to be fixed by Coursera, you may want to try this if you face similar issue:

  1. From the blank notebook, click File -> Open.
  2. Tick the running notebook.
  3. Click Shutdown then Duplicate.
  4. Rename the old notebook (any filename).
  5. Rename the duplicate with the original filename (basically, just remove the -Copy1 string).
  6. Open this newly renamed notebook.
  7. You should be able to save this and also see the submit button after a minute.

Thank you