No Submit Button- Week 1 Assignment

I have no “Submit” button available for my week 1 first assignment, even after
1 . restart kernel + clear output
2 . renaming my file to _v2 and updating the lab version

After the lab update, even the fresh notebook does not have a submit button.
Most of the links on other topics are redirecting to non-existent/deleted pages.

I suspect an issue with a missed deadline, but I can’t find where to reset it.
The second notebook for week 1 (that is also past the deadline) has the Submit button available.

The “Submit Assignment” button only shows up in the “official” notebook (the one opened by the “Work in Browser” link). If you rename it, the renamed copy will not have the Submit button. If you rename it back to the “official” name, it won’t have the submit button until you do “Kernel → Restart and Clear Output”.

I suspect that you are just not quite executing the steps carefully enough. Try “Work in Browser” and then if that does not show you the button, immediately try “Kernel → Restart and Clear Output”.


Hello @derkarldeb ,

Missed deadline assignments are usually locked. If you try to access through an external link or the flow is broken the submit button disappears. However, it can also be network unstability for which the notebook couldn’t load properly.


I would be very surprised if this issue has anything to do with deadlines. The deadlines here are meaningless. There is no penalty for missing them and they just automatically reset. That should have no effect on whether or not you see the “Submit Assignment” button.

Now if your subscription to the course has expired, that would be another matter. But in that case, you should not even be able to open the notebook in the first place. Maybe if you had it already open when your subscription expired? I don’t really have a way to run that experiment, so I’m not sure what would happen in that case.

@paulinpaloalto It is not a subscription issue nor is it an environment issue, as I’ve only been using the “official” notebook from the the “work in browser” link. However I finally managed to get it to work today by redoing the same steps as yesterday, so it’s weird, but at least it ended up working, and thanks for looking into it.

Thank you sir, This was very helpful

Restarting kernel worked

Yes, that’s the first thing to try:

Kernel -> Restart and Clear Output

There is also a topic about this on the DLS FAQ Thread which goes into more detail.

1 Like

I am also facing same problem not able to find submit button. Even after Kernel Reset or Restart and Clear Output.
Please HELP

Did you read all the info in that FAQ topic? There are other things mentioned as well, e.g. to make sure you are not running in a renamed copy of the notebook. And even if you manage to get a “Submit” button there, it will not grade the renamed copy.

Also note that there are at least two places where the button can show up depending on how the given assignment was written: in some cases it’s at the very top center of the window border and in other cases it’s over at the right end of the “toolbar” line.

Hello Paulinpaloalto,
As per best of my understanding I just followed the instruction from the page.
I didnt made any copy

Which assignment is this where you are seeing this problem? Have you successfully completed any other assignments in any of the DLS courses or is this the first assignment you have tried?

  1. I am talking about Week 1 assignment only.
  2. Yes I have completed other assignments I have completed Deep Learning Specialization course set of 5 courses. Hence this is not my first assignment I have tried.

But you filed this message on a thread about DLS C4 W1, so which course are you actually talking about here if you’ve already completed all 5 DLS courses?