Error with the "Transfer Learning with MobileNet" programming assignement


I have a problem with the programming assignement…
It seems like there is a problems with the saving:

Even if I do everything right in the assignement, the file will not be saved. Thus, when I submit it, it will give me a 0/100 grade :frowning:

I tried it on 3 computers, with 3 different browsers, with and withotu incognito mode. Nothing works

I am completely stuck. Could anyone help me?


EDIT: I tried the commands in terminal but it does not work, I do not have the permission

Hi @Parataito,

The problem you have reported is affecting a few courses and we are informed that Coursera is looking into this matter. Before they come up with a fix, one of our course staff has suggested a temporary workaround in this post that will change the permission of an assignment notebook. Would you mind giving it a try and let us know whether it works for you?


Thanks for the quick answer!
I’ll be trying that and I’ll give you a follow up if that works or not!

Thank you for trying it. @Mubsi, please take a look at this.


Ah it’s the same thing that popped-up above my post.
As I said, I tried it, but unfortunately, I do not have the permission to do it.
I’ll wait then !

Yes, I think we need to give them some more time as I was informed that Coursera staff are looking into this issue.

Well, I chatted with one of the support staff this afternoon and he/she said that: “I searched about this error you reached and we do not have records of this being an issue with the Course and assignment”

I guess the poor guy was not aware of it, hope they’ll fix it quickly though :confused:

EDIT: again, thanks for the fast answer, that’s really cool :slight_smile:

Thank you for your understanding, @Parataito :wink:


Found a work-around in another thread: How to Fix read-only/unable to save/unable to submit assignment Issue - #20 by jonathanpsculley

The fix has been published, see the pinned thread at the top of every Discourse page.