Can't save/submit assignment – permission denied (reboot, update doesn't help)

Course: Convolutional Neural Networks, week 2, assignment 1
Lab id: pxiosxcawkzv

Permission denied, autosave failed. Work submit empty.
Rebooting server or getting new version of lab did not help.
I have lost my work twice. Because of that, I am running behind my deadlines, and I would not want to have to pay for the course twice. ((
Please help me fix the issue.
P.S. Just checked, same issue is with the second assignment of the week.

Hi @apodgorny ,

The staff team is working to resolve this issue. Here is a workaround unit the problem is fixed.

I got the exact same problem! I definitely got the test passed, but cannot save my work. It really make me frustrated.

Time is precious. I have really busy schedule. As a sophisticated programmer, I do not believe this is a big issue which you guys cannot solve in 3 hours. What?!! It is really terrible.

i am facing the same issue. unable to submit any of my assignment plus i am close to the deadline

Hi @jiayuecheng ,

Our platform partner, Coursera, is responsible for the backend infrastructure. Our staff team is working with Coursera’s engineers to resolve this issue. The mentors here have no access to the servers. We are just as frustrated as yourself because we know time is precious and taking spare time to study our courses is a huge commitment. Please bear with us. We will post an update as soon as a working solution is found.

1 Like

I have worked through all of the suggested fixes and still getting the “Permission denied” error

Hi @Bryan_Eldridge ,

Could you head over to the news and announcements channel and give details of the problem to the team so that they can target those areas specifically.

Hi, folks!

If this temporary hack didn’t work for you, kindly refer to that post. You will need to submit your info as mentioned there.



I have had a chat with coursera support. No surprise there – they thought the issue has been fixed. I had to prove that it is not and provided screenshots in three different browsers. In the end, they have opened another bug ticket. (Internal ticket number: 03807916)

I have asked, what do we do if the issue is not resolved by the time our subscription ends. They urged me to contact them directly if that happens.

So, guys, please keep bugging them until the issue is fixed, otherwise nobody will do anything. Please refer to the ticket number above. Their support chat icon can be found directly on the assignment page. Good luck!

@apodgorny have you tried this?

Yes. I have tried this. Thank you. It resulted in permission error in a different place.
Either way – coursera does not provide good learning experience. We are not here to spend time on trying hacks – it is a job of their engineers – we are here to learn about what we pay for.

Totally agreed with you…

1 Like

The issue has been solved by coursera stuff. Thanks to community QA – @Mubsi , who took initiative and provided coursera with details on the issue! Thank you!!

1 Like