Permission denied (cannot submit the assignment)

I receive this error when I try to submit my programming assignments. Can anyone help me?

1 Like

Hi Omar! I hope you are doing well.

“Several students are reporting this bug simultaneously, so maybe there is something going wrong on one of the AWS clusters running Coursera.”

Our mentor Paul “asked the course staff for help. The mentors can’t see the backend infrastructure, but hopefully the course staff can either see what is going on or know someone to call at Coursera.”

Kindly wait and someone will get back to you.


1 Like

Thank you so much. I’ll wait :pray:

Hi everyone! Sorry for the delay.

Kindly try this:

  1. From the blank notebook, click File -> Open.
  2. Tick the running notebook.
  3. Click Shutdown then Duplicate.
  4. Rename the old notebook (any filename).
  5. Rename the duplicate with the original filename (basically, just remove the -Copy1 string).
  6. Open this newly renamed notebook.
  7. You should be able to save this and also see the submit button after a minute.

You “might see an error about checkpoints failing. I think that’s okay because that’s related to the permissions of the hidden .ipynb_checkpoints folder. That is not needed for grading as far as I know. The changes should persist in the actual notebook itself even if they see that error. I submitted the notebook and got the expected grade.”



Hi Saif,
I tried to use your solution but encountered another warning saying that I do not have permission while duplicating the file.

Do you mind have a look at this problem?

Thanks in advance!


1 Like

Hi @Cat_X,

Thank you for trying and for the feedback. We are waiting for Cousera for an update about the problem.


1 Like

Hi @Cat_X @Omar_Allam,

Try this temporary hack. It worked for many learners but didn’t work for a few.


1 Like

Thanks a lot, it works for me :heart: