I get a permission denied when I try to save and checkpoint

So when I couldn’t save and checkpoint, because of permission denied, I exited my browser and came back in. When I go to the notebook I get this

This is for programming assignment 2 of DLS Course 4.

This was after submitting the assignment last night, and waking up to see that I had received a 0%. I had executed the Javascript to clear the memory, just like it asked, and then submitted the assignment. That seemed backwards, but it appeared to be what the instructions were saying.


Hello @Edgar_S_Gilchrist_Jr!

Several students facing this issue. We already informed the course staff to look into the issue as soon as possible. We are extremely sorry for the inconvenience caused to you because of this error. We understand how frustrating this is but we have no other option but to wait. Sadly, we don’t know the exact time when the problem will be resolved but hope they will resolve it soon.

Your patience will be highly appreciated. Once they resolve the issue, we will inform you.


Hi @Edgar_S_Gilchrist_Jr,

We informed the Coursera staff about it and waiting to hear from them. We are extremely sorry for the inconvenience. Please wait for a while.
Meanwhile, you can try this temporary hack but it worked for some and didn’t work for others.


Hi Saif,

I tried the workaround, but it didn’t work. I think I will wait for Coursera to fix it.



Please check this one, Ted. This is different from the previous one.

Thanks for your patience.


I think I figured it out I was able to finish the programming assignment and save it and it looks like I got graded and so I’m on to the next week of the course

Wow! That’s great. Could you please share your way, how you resolved that.


I don’t know if it was an advisable way. I executed a chmod 777 on the new folder I had created. I don’t feel comfortable giving this as a tip.