Get Permission denied: W2A1/Residual_Networks.ipynb and unable to checkpoint

Error as in title plus unable to checkpoint (no checkpoint is kept) plus the autograder gives 0% even on code that should be perfect 100%.
Tried to log in on new Chrome browser instance using incognito mode to fake no cookies and no cache plus tried on another Browser (Opera) and no success.
Tried to save as a new file in W2A1/ folder and no luck - Permission denied.
I was able to write to a folder up a level from W2A1/ but that is useless as the autograder wants a hard coded file name W2A1/Residual_Networks.ipynb so I cant submit work so I am stalled.
As I see it my account has no write permissions to the folder W2A1/ that was created for me.

This is a known recent issue with the Coursera platform. They’re working on a fix.
There is a possible work-around posted elsewhere on the forum, I’ll post a link if I can find it.

Try the suggestions here:

Fix was easy for me:
Firstly if you have code you want to save then save the code blocks into a local text file or something so you can copy+paste your code back into the new lab notebook.

In the lab Use the File Open gui to rename the broken W2A1 folder to something like W2A1OLD then create a new folder W2A1 and then in the lab Help do the Get latest version.
The folder name is very important and must be identical to what the assignment wants.
This will populate the newly created W2A1 folder.

Exit the notebook and go back in. It will now open the newly recreated files and they should checkpoint and autosave correctly. If it checkpoints and autosaves then the autograder will work.
Copy and paste in your saved text code and then continue your work or Submit Assignment.

Got my 100% with the fixed files and moved on to parts 2 (W2A2) and it has the same problem. Again I fixed this by original folder rename, create new folder with W2A2 name. Get latest lab version and then start the lab.
THe root cause is that when the lab was recently updated on March 28th I think then whoever did that did not correctly do whatever it is they did. This left files in the W2A1 and W2A2 folder with the incorrect permissions (possibly their ownership but certainly not mine).

Time to identify this was a day. Please identify who updated the labs for these two course assignments and correct their procedules.

That’s great, Lincoln. :+1: :+1: :+1:

Coursera staff is still working on it.


Update: The issue appears to have been fixed. Please follow the instructions in the thread banner message.