Lab 3 Not getting the right compute

Hi All,

I am not able to select large kernel: Recommended is “8vCPU + 32 GiB” but I am not able to select anything else other than “2vCPU + 4 GiB”. And because of that Lab is crashing and Kernal is getting restarted on following code:

toxicity_evaluator = evaluate.load(“toxicity”,

Please help as tomorrow is the last date of submission. I need to finish this.


1 Like


It’s important to select the instance with the exact name as provided in the instructions. When I did this course the instance name was: Ml.m5.2xlarge.

1 Like

For me it is not letting me select large but only Medium.

1 Like

The python notebook is not letting me select any instance type other than the default ml.m5.medium 2 vCPU and 4 GiB RAM.

1 Like

Someone said you should select the second instance ml.m5.2xlarge.

If it doesn’t work, use this form to ask for help.

1 Like

I have struggled with this issue for several days.

The team at Vocareum have confirmed they can’t change the machine on their side; it needs to be done by Coursera.

This is very disappointing. Every lab for me has been riddled with various problems, as noted here and elsewhere.

1 Like

Okay, it has loaded the “right” kernel and I’ve been able to complete the lab.

Unfortunately, I can’t offer any guidance as to why it started to work. I have tried it over 20 times across three days and two different laptops. I tried all the kernels equivalent to the target spec (ml.m5.2xlarge).

After posting here, I gave it one more go and it worked. I can’t explain why.

1 Like