Lab assignment cant load on jupyter notebook

I tried rebooting clearing cache and cookies but still, I cant access my lab it keeps on popping lab session expired please reload.



  1. make sure you have a valid subscription (paid or by financial aid)

  2. try to use the incognito mode of your browser to login coursera and open the lab; or you may try to open the lab on a different device such as your smart phone.

Please post a screenshot of the error if you have a valid subscription and you still have problem after trying (2).


1 Like

Thanks for reaching out. i have financial aid and it was working fine on the algebra for ML.but when I got to the programming assignment for ML it pops this :point_down: and i tried incognito too still nothing

In that case please contact coursera for assistant. We can only share past experience with you here, but we are not coursera staff and so we don’t have control over the lab platform. You can find contact method here.

I suggest you to also try your smart phone.

1 Like

thanks again… smart phone screens are not compatible with the lab. and they are unavilable. thanks for trying to help

The good thing about trying smart phone is just to see whether you can open the lab. If you can open the lab, then it’s likely to be your laptop’s problem and therefore you may want to clear the browser’s cache before you try again on the laptop. I am not suggesting you to work on the notebook on your smart phone.

1 Like

Ok, I will try a different laptop. I already cleared everything on this one.

and you seem nice can I ask you questions in the future ML related? I got an internship as a machine learning engineer and I can use help.

Please ask your questions in the community so that I or other community members can contribute. Besides the MLS categories, there is also a general discussion category for questions not about any specialization.

1 Like

IT WORKED … i guess i have to submit then through my phone

Since you will try a different laptop, hopefully you will find one that works as well.

1 Like

Hello @dagim_alemu,

I recently saw 2 cases that the “timed out” problem can be caused by wrong system’s time. If you still have that issue, you might want to make sure your laptop’s system time is correct.


thanks a lot … it fixed it :+1:

1 Like


(20 characters limit)