Lab week 3: ‘TFX on Google Cloud Vertex Pipelines’ missing notebook

Upon starting this lab and navigating to VertexAI/Workbench, I found that the notebook was missing. I contacted support, and what follows is the response:

We are really sorry for the inconvenience caused.
As there is an ongoing issue with this lab, we have already forwarded this case to the concerned team. Currently, we do not have an ETA regarding the fix for the lab. Although, we will provide you the update on this once the issue gets resolved on the highest priority.

I will update this when (if?) I receive an update.

1 Like

I m also facing this problem.

Hi! Thank you for reporting! We’ll take a look and escalate the issue to our partners if needed. Will update this thread asap.

Hi, I am done with all the course modules, the only item preventing me from completing the specialization is the [TFX on Google Cloud Vertex Pipelines’ missing notebook] issue. My subscription ends today 31-Aug and I don’t want to be billed for a new subscription by 1-Sept. Pls, how will this be addressed if the issue is not resolved in time?

Hi Segun! Welcome to the community and apologies for the situation! Kindly contact Coursera (chat instructions here) and tell the agent that the lab is broken and may take a while to repair. He/she may have recommendations on how to delay the renewal. Please clarify that this lab, when fixed, takes less than an hour to complete so you should have made it before your next billing cycle. Please let me know what response you got.

There might be a workaround on how to complete the lab but I have to have it approved by our partners’ Engineering Team. Hopefully, we’ll get a positive response. This issue is newly reported so we haven’t received instructions yet from their team. Will update this thread as soon as I hear from them. Thank you!

I contacted QwikLabs about it. It is fine now, I can see the notebook.
The new issue now is that the notebook kernel always dies during pip install
and i have not gone beyond that cell. I have sent screenshots to QwikLabs but no response yet.

Still no response, but I changed the kernel from Python-3 to kernel ‘vertex_pipelines_simple.ipynb’
and the notebook was able to continue.

It seems that, for some reason, ResNet models in other assignments also don’t work well. I just finished " Implementing Canary Releases" and although I was able to go through as the lab was focused on canary deployment, I couldn’t make the request work with curl. Repetively, I was getting the following error, independent on the model used:
upstream connect error or disconnect/reset before headers. reset reason: connection terminationstudent_01_e2794b3bbe1b@cloudshell
I had a similar issue with previous exercise in graded exercise in week2 (Autoscaling TensorFlow model deployments); to complete the lab I had to use brute force to overwhelm kubernetes from a few terminals.
Any ideas what should be done with this information? I would be happy to report it, for now I just left a note while rating the lab

Really? That’s weird, the notebook isn’t there for me. I’ve been waiting for a while and refreshing the page and nothing. Was it there for you at the moment that you selected the Workbench in Vertex AI?

Hi everyone! Unfortunately, we haven’t received any feedback from the Google Team yet. Will follow up. In the meantime, please try reaching out to a Qwiklabs support agent as Segun has done. You can select the Chat Support option for quicker replies. They might be able to troubleshoot your particular instance of the lab.

Screen Shot 2022-09-02 at 8.05.53 PM

Will update this thread as soon as we hear from our partners. Thanks!

Hi Lukasz! Welcome to the community and thank you for reporting! I haven’t encountered those issues before so thanks as well for suggesting possible workarounds. Will keep it in mind when we get similar reports. We’ll also investigate if this is a recurring issue so we can escalate it to our partners.

If you haven’t finished the “Implementing Canary Releases” yet, please create a separate topic with a related title so it will be more visible to the mentors and other learners. It will make the forums easier to navigate. Thank you!

Hi, I faced the same issue a few weeks ago. I tried a few times without success and gave up for the day. The next day it ran like a charm, the notebook was like as expected. So it’s not really a workaround, but hopefully it will work for you too.

I just completed the lab without any errors. Maybe the issue is solved now.

Hello Lukasz! Is this the error you were having for the week 2 graded lab?

If so, I have provided a temporary solution by changing the tf-serving image used for kubernetes deployment. I hope this helps.

1 Like

Hi Segun,

can you please help me the contact of the Qwiklab, I am also facing the same error like you.

Hi Renga! Welcome to the community! Please see the second point here. That should get you in touch with a Qwiklabs agent. Thanks.

Hi everyone,

I was experiencing the same problem. I simply provisioned a new notebook by clicking “+ NEW NOTEBOOK” at the top of the page and navigating to TensorFlow Enterprise, then “TensorFlow Enterprise 2.9”, then “Without GPUs”. I ensured that the selected Region was “us-east1” to match variables in the downloaded repository. I tried version TensorFlow Enterprise 2.8 and had issues with the runtime, but 2.9 worked. Once the notebook was provisioned, I had no issues completing the lab.

Hopefully this will be a suitable workaround until the auto-provisioned notebook issue is resolved.


1 Like

Hi Alex! Welcome to the community and thank you for suggesting this! I also arrived at a similar workaround and asked our partners if we can recommend it to the learners while the lab is still being fixed. We haven’t gotten the approval yet though. Will follow up again today. Thanks!

Hi! Our partners said that they pushed an update to the lab. Kindly post here in case you’re still not seeing the pre-provisioned notebook. You can refresh the workbench after 10 to 15 minutes to make sure. Thank you!

I opened this topic 9 days ago. Today I ran the lab and it finally ran without any hiccups. Thanks, everyone for all the effort and suggested workarounds.

BTW - It took 8 days to get a reply from Qwicklabs support

1 Like

Awesome! Thank you for confirming that it works! Hope the other learners also see the notebook now.