Lab2 : impossible to finish it. Encountering Kernel death

Hi,

During Lab2 of the “Generative AI with Large Language Models” course, I systematically encounter the following error message which prevents me from completing the lab.
Is there something to do to prevent that?

image

Thank you

1 Like

Hi @Amaury1

Welcome to the community.

we can try a basic troubleshooting in order to clean any cache that might be affecting you:

  • Check Internet Connection: Ensure that your internet connection is stable. If you’re not able to load any websites, it might be an issue with your connection.

  • Clear Browser Cache and Cookies: Over time, cached data and cookies can cause issues. Clear your browser’s cache and cookies to see if it resolves the problem. This varies depending on the browser, but it’s usually found in the settings or options menu.

  • Disable Browser Extensions: Browser extensions can sometimes cause conflicts or slow down your browser. Try disabling all extensions to see if the problem persists. If the issue is resolved, enable the extensions one by one to identify the problematic one.

  • Update Your Browser: Ensure that your browser is up to date. Outdated browsers can have compatibility issues with modern websites. Update your browser to the latest version available.

  • Try a Different Browser: If the problem is specific to one browser, try using a different browser to see if the issue persists. This can help determine if the problem is browser-related or a system-wide issue.

  • Disable Hardware Acceleration: Some browsers use hardware acceleration to improve performance. However, this can sometimes cause problems. Try disabling hardware acceleration in your browser’s settings.

  • Reset Browser Settings: If none of the above steps work, you can consider resetting your browser settings to their default state. This will remove any customizations but might resolve the issue.

Remember that troubleshooting can be a trial-and-error process. It’s important to isolate the problem step by step to identify the root cause.

I hope this help

elirod

While full finetuning the model is occupying all available VRAM, i tried it to run on my colab having 15GB VRAM there also the model finetuning occupied all available VRAM.
Allow access to larger VRAM GPUs in order to do full finetuning.
When i ran the same code on my colab PRO it worked. So allow access to atleast 16GB VRAM in order to run the .ipynb file provided.

Disabling all extension, clearing cache and cookies did not worked for me, my internet connection is good.
Please suggest me if any other way is possible.
Thank You !

I’m having the same problem!
Did all the recomendations as well, and it didn’t solve. I was getting a permission error 403.
When opening again from Vocareum Labs, I can’t even start it again:

Does anyone at leas have the ipynb file to download? I completely lost access to it. HELP

Hi!

Thanks for your replies.

As said by Anuj, the problem seems to stem from the available VRAM. I systematically get the kernel error while trying fine-tuning or PEFT.

It would be great to indeed have access to higher VRAM (all other instance types beside the general purpose one at 4 GB are unauthorized).

Best,

I have the same problem, cannot run the notebook

Hey…I am encountering the same issue. Were you able to solve this problem from the suggestions given here?

Hi,

One of the bigger instances is actually available to us :

image

It solves the kernel issue.

It will also probably be better to choose this specific instance for Lab 3 too :slight_smile:

1 Like

This helped! Thanks, Amaury!

Thanks a ton. You saved me. I wish I saw this earlier. I saw this when I was already thinking of leaving the course!!!

Thanks for telling me! Happy to have been of help :slight_smile: