Gen AI with LLMs Lab issue assignment 2

In the assignment notebook it says make sure 8vCPU+32Gib is selected for kernel. 2vCPU+4Gib is the Kernel auto assigned by Sagemaker for me and I get permission error when I try changing it to something higher.
I go on through the lab but when I try execute trainer.train() in section 2 Fine Tune the model with the preprocessed dataset I get an error after a minute or so that The kernel for Lab_2_fine_tune_generative_ai_model.ipynb appears to have died. It will restart automatically.
After this I have gone back and attempted twice but get the same error.

ml.t3.medium is default kernel and I am unable to select anything else

I attempted to redo the lab again by relaunching amazon sagemaker after the “kernel died” error mentioned above but got the error below.

File Save Error for Lab_2_fine_tune_generative_ai_model.ipynb

Invalid response: 403 Forbidden

Hi. It seems you’re using a different instance type. Please check the screenshot in the notebook and make sure you’re selecting the one specified there. It’s most likely ml.m5.2xlarge but please double check. Almost all errors like this stems from that. Hope this helps!

When I open the lab notebook I get the default instance type as shown here
Instance type: ml.t3.medium 2vCPU+4GiB.
When I try to change it the option ml.m5.2xlarge you have suggested is not even available for selection as you can see from the screen shot above. When I try to select anything among the available choices I get this error(Failed to start Kernel. Access denied

Hi. ml.m5.2xlarge is below the “All Instances” section in your screenshot above. It is further down. It is not under the “Fast Launch” section. I just tested it yesterday and was able to find it.

Chris favila Thanks very very much. Your confident assertion made me look even more carefully at the button to click for getting all the selections.

1 Like

Glad to help!