My student account does not have proper permissions

I get error messages complaining my account has no authorization to access sagemaker:
AccessDeniedException

User: arn:aws:sts::155283213483:assumed-role/voclabs/user2696198=Roger_Krimstock is not authorized to perform: sagemaker:ListDomains on resource: arn:aws:sagemaker:us-west-1:155283213483:domain/* with an explicit deny in a service control policy

I see a response from graham_broughton suggesting trying again later. Of course, that puts me in the position having to wait up to 20 minutes to start, when resources are finally accessible, sigh.



To close this (at least for me), exiting and re-logging worked. There was an error message that I ignored. I was then able to work the lab.

Hi Roger. Sorry to hear that. I’m not yet sure, but I think the resources should be created in us-east-1 while the error message indicates trying to do so in us-west-1. I’ll check with the team. It might be just a glitch, and glad that it worked on your next attempt. Thanks for updating!