Programming Assignment: Exercise 1 (submission.json error)

Hello everybody,
After completing the assignment, I fail grading with the following output: “Your solution should have 26 code-cells, but you have 27”.
Any Idea on how can i fix this? Alternatively, do you know how can I restore the notebook to its initial configuration, so that I can redo it from the beginning?

UPDATE: I solved just refreshing the notebook and redoing it again. It seems that if you add any new line the grader fails.

1 Like

Hi Giuseppe! Sorry for the late reply and thank you for updating the topic with the solution. Yes adding new lines will most likely halt the grader. We’ll publish some tips soon to get around common grader issues for this course. Thank you!

I am trying to reinitialize my notebook but I cannot! I reboot, re-connect to the Kernel, and pretty much everything that was recommeneded but I cannot get the first version to redo my code. Would you please help me about that?
I got the same error: “Your solution should have 26 code-cells, but you have 27”

Hi Ramin! Welcome to the community! Have you tried the steps here to refresh your notebook? You should have a clean notebook with the original filename after that. From there, you can copy paste your solutions from the old one into this new notebook, then save and resubmit. Please do not add any code cells, else you will get the error you mentioned. Hope it works!

Hi Chris,
Thanks for your reply. I tried that and it worked.
Thank you again


Great! Glad to hear that!

Hi, there no way to access the notebook for the assignment. C2W1

1 Like

Hi Imokut. I’m not sure what you mean. Maybe there’s just a temporary outage. Hope you can access the notebook now.

Yeah. I accessed it later

1 Like